summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-16 02:31:20 +0100
committerSam James <sam@gentoo.org>2023-05-16 02:52:19 +0100
commit04b0a279625e6fce95cf9f36a6711ceb9530a89b (patch)
tree92cc92bde7048c9c285956e0f2dff5058ffea0cb
parentsys-cluster/mpich: add Valgrind annotation support (diff)
downloadgentoo-04b0a279625e6fce95cf9f36a6711ceb9530a89b.tar.gz
gentoo-04b0a279625e6fce95cf9f36a6711ceb9530a89b.tar.bz2
gentoo-04b0a279625e6fce95cf9f36a6711ceb9530a89b.zip
net-misc/openvswitch: add Valgrind annotation support
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.6.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/openvswitch/openvswitch-2.17.6.ebuild b/net-misc/openvswitch/openvswitch-2.17.6.ebuild
index f6fd673f3545..1edab262a4b7 100644
--- a/net-misc/openvswitch/openvswitch-2.17.6.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.17.6.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="debug modules monitor +ssl unwind"
+IUSE="debug modules monitor +ssl unwind valgrind"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Check python/ovs/version.py in tarball for dev-python/ovs dep
@@ -29,7 +29,8 @@ RDEPEND="${PYTHON_DEPS}
unwind? ( sys-libs/libunwind:= )
ssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}
- sys-apps/util-linux[caps]"
+ sys-apps/util-linux[caps]
+ valgrind? ( dev-util/valgrind )"
BDEPEND="virtual/pkgconfig"
PATCHES=(
@@ -80,6 +81,8 @@ src_configure() {
# want to add a BDEPEND on graphviz right now. bug #856286
export ovs_cv_dot="no"
+ export ac_cv_header_valgrind_valgrind_h=$(usex valgrind)
+
local linux_config
use modules && linux_config="--with-linux=${KV_OUT_DIR}"