summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-30 12:15:26 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-04-29 11:45:18 +0300
commit04c9f8a06b032ae4c09f6bdc26de92aa5b4df7bc (patch)
treefd0d20d6be975147888c27ef94bb41cdca7c7792
parentgames-emulation/jgrf: add 1.1.0 (diff)
downloadgentoo-04c9f8a06b032ae4c09f6bdc26de92aa5b4df7bc.tar.gz
gentoo-04c9f8a06b032ae4c09f6bdc26de92aa5b4df7bc.tar.bz2
gentoo-04c9f8a06b032ae4c09f6bdc26de92aa5b4df7bc.zip
games-emulation/bsnes-jg: add 1.2.0
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-emulation/bsnes-jg/Manifest1
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-emulation/bsnes-jg/Manifest b/games-emulation/bsnes-jg/Manifest
index be59e5809a5e..8fa3da84c341 100644
--- a/games-emulation/bsnes-jg/Manifest
+++ b/games-emulation/bsnes-jg/Manifest
@@ -1 +1,2 @@
DIST bsnes-1.1.2.tar.bz2 4183035 BLAKE2B 09e01845fb9e6208f5262e2abef14c46e9fa53cfdd025821345507fc68e520dc21ca69e5d712a7f821936166975865c26dc0be42549b551abdbb941e748949b1 SHA512 77cb82b6cba2941813de25273bd74b928ad380dccadb909ae3500ddf6f8906504f5400df95381569d35fc7b06e0330f9eb4d54d88d64a5c698925d54df62bada
+DIST bsnes-1.2.0.tar.bz2 4277380 BLAKE2B 03abb6efdf2e2fe487ddea780f9a3053092e718695d7f875304a008f5e3e967c443f3ad40d7c8a82b07d66c52ead5d258018fd004cb205efaaa872b122057c98 SHA512 96aaeecf10508bc7672c30fa24b34e0d32e34c4190928109a141f4a1d73fb6f007844f9b7154ffc57028ddb9e99b5c281a214b9517ce5de618cf229722ff1e20
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.2.0.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.2.0.ebuild
new file mode 100644
index 000000000000..243ad0946b1d
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-1.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}