summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-04-03 02:04:53 +0200
committerDavide Pesavento <pesa@gentoo.org>2019-04-03 03:00:03 +0200
commit04d72718957bc2e95d3b22bb925b488490759204 (patch)
tree184b96f3bb8a61076a78f8a01014d9cfe7657d4a
parentdev-python/PyQt5: proper fix for the parallel install failure (diff)
downloadgentoo-04d72718.tar.gz
gentoo-04d72718.tar.bz2
gentoo-04d72718.zip
dev-python/qscintilla-python: proper fix for the parallel install failure
Also switch to an out-of-source build Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.11.1.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.11.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.11.1.ebuild
index dfe6ef7c314a..4c02bf5f03f6 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.11.1.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.11.1.ebuild
@@ -6,11 +6,16 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit python-r1 qmake-utils
-MY_P=QScintilla_gpl-${PV/_pre/.dev}
-
DESCRIPTION="Python bindings for QScintilla"
HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-SRC_URI="https://www.riverbankcomputing.com/static/Downloads/QScintilla/${MY_P}.tar.gz"
+
+MY_PN=QScintilla
+MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
LICENSE="GPL-3"
SLOT="0"
@@ -33,27 +38,24 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}/Python
-src_prepare() {
- default
- python_copy_sources
-}
-
src_configure() {
configuration() {
local myconf=(
"${PYTHON}"
- configure.py
+ "${S}"/configure.py
--pyqt=PyQt5
--qmake="$(qt5_get_bindir)"/qmake
- --sip-incdir="$(python_get_includedir)"
$(usex debug '--debug --trace' '')
--verbose
)
echo "${myconf[@]}"
"${myconf[@]}" || die
- # Run eqmake to respect toolchain, build flags, and prevent stripping
- eqmake5 -recursive
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets' ${MY_PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${MY_PN}.pro
}
python_foreach_impl run_in_build_dir configuration
}
@@ -64,8 +66,7 @@ src_compile() {
src_install() {
installation() {
- # parallel install fails because mk_distinfo.py runs too early
- emake -j1 INSTALL_ROOT="${D}" install
+ emake INSTALL_ROOT="${D}" install
python_optimize
}
python_foreach_impl run_in_build_dir installation