summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-09-30 07:57:49 -0500
committerBen Kohler <bkohler@gentoo.org>2022-09-30 07:58:09 -0500
commit04e87feb89d0abe22b016eba58e8281462e11243 (patch)
treeea61c912e896d04499aa368fc33c422c5f282e8c
parentdev-games/godot: add 4.0_beta2 (diff)
downloadgentoo-04e87feb.tar.gz
gentoo-04e87feb.tar.bz2
gentoo-04e87feb.zip
sys-apps/memtest86-bin: add 10.0
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--sys-apps/memtest86-bin/Manifest1
-rw-r--r--sys-apps/memtest86-bin/memtest86-bin-10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/memtest86-bin/Manifest b/sys-apps/memtest86-bin/Manifest
index dd2b28717705..677bf41a040c 100644
--- a/sys-apps/memtest86-bin/Manifest
+++ b/sys-apps/memtest86-bin/Manifest
@@ -1 +1,2 @@
+DIST memtest86-bin-10.0.zip 9369041 BLAKE2B c5792b45ee0b9e32013ad64d17e43d6da4ffd80160a913fbd3b82390dd1d7d5e6ca226730fffab01ee6cb36d66b2a78e66d0bfd7a1dd4b07546550e268bc18f5 SHA512 b08e6cf3cb9448d5ac7fb4ba7c6338d2037caebd16710f4c2897cfe73766d7dfba7a0012b1ec5acbc546932e989c2a82bec1428295ea0bf4702e49d75e5b03e1
DIST memtest86-bin-9.4.zip 8760207 BLAKE2B a4db434f9ce049d14b7a7bd98ed88ecad5492e4541d564520eba60b9c37d40d22bdf27ec92f05f3601453647ee88486caf51259bf90a72954b29c8eecbd36ca9 SHA512 c5a6183e2b66fe6023a7478ddfecf94dab03e99272d916fe156f05e2edcc2e70c7cd12feff474381571213bd6b07c76b78dd54d07f2db011cbe3127dac2dc222
diff --git a/sys-apps/memtest86-bin/memtest86-bin-10.0.ebuild b/sys-apps/memtest86-bin/memtest86-bin-10.0.ebuild
new file mode 100644
index 000000000000..9e0a77415687
--- /dev/null
+++ b/sys-apps/memtest86-bin/memtest86-bin-10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+DESCRIPTION="Stand alone memory testing software for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="https://www.memtest86.com/downloads/memtest86-usb.zip -> ${P}.zip"
+
+LICENSE="PassMark-EULA"
+RESTRICT="mirror bindist"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+BDEPEND="app-arch/unzip
+ sys-fs/fatcat"
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ fatcat -O 1048576 -r /EFI/BOOT/BOOTX64.efi memtest86-usb.img > ${PN}.efi || die
+}
+
+src_install() {
+ insinto /boot
+ doins ${PN}.efi
+
+ exeinto /etc/grub.d/
+ newexe "${FILESDIR}"/${PN}-grub.d 39_memtest86-bin
+
+ dodoc MemTest86_User_Guide_UEFI.pdf
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+
+ if [ ! -e /sys/firmware/efi ]; then
+ ewarn "WARNING: You appear to be booted in BIOS mode but ${PN} is an EFI-only tool."
+ fi
+}