summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-08-27 15:18:19 +0200
committerJonas Stein <jstein@gentoo.org>2017-08-27 15:18:19 +0200
commit04fb7b4ab5db121398db6c77ebd88422ee6e8bc5 (patch)
treeedc9ebdf0c68b41de92fefcc8ec2372b48371456
parentapp-misc/ttyrec: Update HOMEPAGE (diff)
downloadgentoo-04fb7b4a.tar.gz
gentoo-04fb7b4a.tar.bz2
gentoo-04fb7b4a.zip
app-misc/ttyrec: Bump to EAPI=6, cleaned ebuild
The Makefile was patched not ideally and was never used * repaired Makefile * bumped to EAPI=6 * cleaned ebuild Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--app-misc/ttyrec/files/ttyrec-1.0.8-flags.patch19
-rw-r--r--app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild21
2 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/ttyrec/files/ttyrec-1.0.8-flags.patch b/app-misc/ttyrec/files/ttyrec-1.0.8-flags.patch
new file mode 100644
index 000000000000..34687d9b8b7a
--- /dev/null
+++ b/app-misc/ttyrec/files/ttyrec-1.0.8-flags.patch
@@ -0,0 +1,19 @@
+--- a/Makefile 2017-08-26 11:47:02.981266309 +0200
++++ b/Makefile 2017-08-26 14:33:47.161600445 +0200
+@@ -10,13 +10,13 @@
+ all: $(TARGET)
+
+ ttyrec: ttyrec.o io.o
+- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o ttyrec ttyrec.o io.o
+
+ ttyplay: ttyplay.o io.o
+- $(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o ttyplay ttyplay.o io.o
+
+ ttytime: ttytime.o io.o
+- $(CC) $(CFLAGS) -o ttytime ttytime.o io.o
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o ttytime ttytime.o io.o
+
+ clean:
+ rm -f *.o $(TARGET) ttyrecord *~
diff --git a/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild b/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..0d2cb545ef30
--- /dev/null
+++ b/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The tty recorder provides tools to record and replay a terminal session."
+HOMEPAGE="http://0xcc.net/ttyrec/"
+SRC_URI="http://0xcc.net/ttyrec/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+PATCHES=( "${FILESDIR}/${P}-flags.patch" )
+
+src_install() {
+ dobin ttyrec ttyplay ttytime
+ dodoc README
+ doman *.1
+}