summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Miller <alex.miller@gmx.de>2024-03-07 17:20:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 17:25:01 +0100
commit04fccf1a5989fcaece707be1ada8824da0fa9318 (patch)
treed359a52e92f886a1ee5e259c8c1ad823903cadbb
parentapp-arch/torrentzip: add 1.3 (diff)
downloadgentoo-04fccf1a5989fcaece707be1ada8824da0fa9318.tar.gz
gentoo-04fccf1a5989fcaece707be1ada8824da0fa9318.tar.bz2
gentoo-04fccf1a5989fcaece707be1ada8824da0fa9318.zip
dev-util/nihtest: New package, add version 1.5.0
A dependency of the new test suite in app-arch/torrentzip.1.3. Tests not enabled yet. Signed-off-by: Alexander Miller <alex.miller@gmx.de> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/nihtest/Manifest1
-rw-r--r--dev-util/nihtest/metadata.xml17
-rw-r--r--dev-util/nihtest/nihtest-1.5.0.ebuild37
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/nihtest/Manifest b/dev-util/nihtest/Manifest
new file mode 100644
index 000000000000..49cf95f7d2b8
--- /dev/null
+++ b/dev-util/nihtest/Manifest
@@ -0,0 +1 @@
+DIST nihtest-1.5.0.tar.gz 39258 BLAKE2B 6f2bf228d080a705ac9c7a56e7f73cd6000e03fae09dc9076eb7c9003f8cd9629690ccc2860c7939461edc089f8e73419232ed08bc131f9b526f141b434f33f8 SHA512 aac6167c18b5af3f49f5b43b6a218f3f3921d5b0bfe74df546a6808cf826debbe587de44b04baf1d4abd8e0c193da1b86a1f6490cc6bd7888b7707e261a1ebcf
diff --git a/dev-util/nihtest/metadata.xml b/dev-util/nihtest/metadata.xml
new file mode 100644
index 000000000000..d1ef0e8cf6e2
--- /dev/null
+++ b/dev-util/nihtest/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>alex.miller@gmx.de</email>
+ <description>Alexander Miller</description>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">nih-at/nihtest</remote-id>
+ <remote-id type="pypi">nihtest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/nihtest/nihtest-1.5.0.ebuild b/dev-util/nihtest/nihtest-1.5.0.ebuild
new file mode 100644
index 000000000000..e71045c4aa7e
--- /dev/null
+++ b/dev-util/nihtest/nihtest-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A testing tool for command line utilities"
+HOMEPAGE="
+ https://nih.at/nihtest/
+ https://github.com/nih-at/nihtest
+ https://pypi.org/project/nihtest/
+"
+SRC_URI+="
+ https://nih.at/nihtest/${P}.tar.gz
+ https://github.com/nih-at/nihtest/releases/download/v${PV}/${P}.tar.gz
+"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/python-dateutil[${PYTHON_USEDEP}]')
+"
+
+DOCS=( NEWS.md README.md TODO.md )
+
+src_install() {
+ distutils-r1_src_install
+ newman manpages/nihtest.man nihtest.1
+ newman manpages/nihtest.conf.man nihtest.conf.5
+ newman manpages/nihtest-case.man nihtest-case.5
+}