summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2024-02-10 20:47:25 -0500
committerSam James <sam@gentoo.org>2024-02-11 05:59:50 +0000
commit051355c623854159c59fa1af75c4fbb7dbb8993e (patch)
treee7bf21c9bfb215b2c21eacf20b9fe20870aff34f
parentapp-emulation/wine-staging: add 9.2 (diff)
downloadgentoo-051355c623854159c59fa1af75c4fbb7dbb8993e.tar.gz
gentoo-051355c623854159c59fa1af75c4fbb7dbb8993e.tar.bz2
gentoo-051355c623854159c59fa1af75c4fbb7dbb8993e.zip
dev-lang/rust: rebase and re-apply musl dynamic linking patch for 1.75
This somehow got lost in the 1.75 bump, but it is required for e.g. Firefox to compile on musl. Bug: https://bugs.gentoo.org/922880 Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/35267 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/rust/files/1.75.0-musl-dynamic-linking.patch19
-rw-r--r--dev-lang/rust/rust-1.75.0-r1.ebuild (renamed from dev-lang/rust/rust-1.75.0.ebuild)1
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-lang/rust/files/1.75.0-musl-dynamic-linking.patch b/dev-lang/rust/files/1.75.0-musl-dynamic-linking.patch
new file mode 100644
index 000000000000..7dc34f8ad6b8
--- /dev/null
+++ b/dev-lang/rust/files/1.75.0-musl-dynamic-linking.patch
@@ -0,0 +1,19 @@
+From e42709c46647dab342b826d30324f3e6e5590e00 Mon Sep 17 00:00:00 2001
+From: Jory Pratt <anarchy@gentoo.org>
+Date: Tue, 2 Aug 2022 18:32:53 -0500
+Subject: [PATCH] Enable dynamic linking by default for musl
+
+Signed-off-by: Jory Pratt <anarchy@gentoo.org>
+--- a/compiler/rustc_target/src/spec/base/linux_musl.rs
++++ b/compiler/rustc_target/src/spec/base/linux_musl.rs
+@@ -10,7 +10,7 @@ pub fn opts() -> TargetOptions {
+ base.crt_objects_fallback = Some(CrtObjectsFallback::Musl);
+
+ // These targets statically link libc by default
+- base.crt_static_default = true;
++ base.crt_static_default = false;
+
+ base
+ }
+--
+2.35.1
diff --git a/dev-lang/rust/rust-1.75.0.ebuild b/dev-lang/rust/rust-1.75.0-r1.ebuild
index 1c9761e003fe..19b85fcb4ae6 100644
--- a/dev-lang/rust/rust-1.75.0.ebuild
+++ b/dev-lang/rust/rust-1.75.0-r1.ebuild
@@ -163,6 +163,7 @@ RESTRICT="test"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/rust.asc
PATCHES=(
+ "${FILESDIR}"/1.75.0-musl-dynamic-linking.patch
"${FILESDIR}"/1.74.1-cross-compile-libz.patch
#"${FILESDIR}"/1.72.0-bump-libc-deps-to-0.2.146.patch # pending refresh
"${FILESDIR}"/1.70.0-ignore-broken-and-non-applicable-tests.patch