summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-02-10 03:09:05 +0200
committerStefan Strogin <steils@gentoo.org>2020-02-10 03:11:37 +0200
commit051ba174b8fe5f83e22d6bb3bc2240c96799c2be (patch)
tree2c4dc442306ac7bd0d5023e22b98c741220bca6b
parentdev-ml/camlp5: restricted 7.10 wrt ocaml (diff)
downloadgentoo-051ba174.tar.gz
gentoo-051ba174.tar.bz2
gentoo-051ba174.zip
games-action/extreme-tuxracer: version bump to 0.7.5
EAPI=7; move from gnome2-utils to xdg-utils. Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--games-action/extreme-tuxracer/Manifest1
-rw-r--r--games-action/extreme-tuxracer/extreme-tuxracer-0.7.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/games-action/extreme-tuxracer/Manifest b/games-action/extreme-tuxracer/Manifest
index a7043b6c193b..dd0e5708ac95 100644
--- a/games-action/extreme-tuxracer/Manifest
+++ b/games-action/extreme-tuxracer/Manifest
@@ -1 +1,2 @@
DIST etr-0.7.4.tar.xz 44179876 BLAKE2B 040554b8053e7f513526b539479dddd3740e002348e169453dcbd1cec28fa15e1abff13c1b02cbd61552d04974e3ec508b0d9b24e1162e4d113f284103b877d9 SHA512 780263859ee3510b0c421f10c190b479db62a1268def14f18ecf7ff84c470cf28f1a2b077fcb21d8bd447cde8b3a7f280aced5cd830eb3aa174b3e461e9efae1
+DIST extreme-tuxracer-0.7.5.tar.xz 44180024 BLAKE2B 6c4cb4cdfe19e376a6bc5fa164ea17592f0aa46b5d297957219a501e8b294e3a071909b2ce168424e734e1d06a5ef81647d5a392e6943b71a6bafd50890206e3 SHA512 62ea5ccdacb3e793760fe793133f1866179dffd938fd4b8e5c369371d847320a247bf85a89648b7c01078dc18a65ac6eac30a59bfe710032c79c16ab93f9e4aa
diff --git a/games-action/extreme-tuxracer/extreme-tuxracer-0.7.5.ebuild b/games-action/extreme-tuxracer/extreme-tuxracer-0.7.5.ebuild
new file mode 100644
index 000000000000..37ca8a6dbf5b
--- /dev/null
+++ b/games-action/extreme-tuxracer/extreme-tuxracer-0.7.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg-utils
+
+DESCRIPTION="High speed arctic racing game based on Tux Racer"
+HOMEPAGE="https://extremetuxracer.sourceforge.net"
+SRC_URI="https://download.sourceforge.net/extremetuxracer/etr-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsfml:0=
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/etr-${PV/_/}"
+
+src_prepare() {
+ default
+ # kind of ugly in there so we'll do it ourselves
+ sed -i -e '/SUBDIRS/s/resources doc//' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{code,courses_events,guide,score_algorithm}
+ doicon -s 48 resources/etr.png
+ doicon -s scalable resources/etr.svg
+ domenu resources/etr.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}