summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-15 11:37:34 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-15 11:42:47 +0200
commit0547b99ec1b1c13c949b16053a3967823658377f (patch)
tree442412dfabd9fc9a20ea8931628203c2d0b2f949
parentapp-emulation/dlx: Update HOMEPAGE, version distfile (diff)
downloadgentoo-0547b99ec1b1c13c949b16053a3967823658377f.tar.gz
gentoo-0547b99ec1b1c13c949b16053a3967823658377f.tar.bz2
gentoo-0547b99ec1b1c13c949b16053a3967823658377f.zip
app-emulation/dlx: Bump to 1.5.20, major cleanup
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-emulation/dlx/Manifest1
-rw-r--r--app-emulation/dlx/dlx-1.5.20.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/dlx/Manifest b/app-emulation/dlx/Manifest
index 4de82a978b28..d495844051b6 100644
--- a/app-emulation/dlx/Manifest
+++ b/app-emulation/dlx/Manifest
@@ -1 +1,2 @@
DIST dlx-1.0.0.tar.gz 112589 BLAKE2B 307785d08fd69e45264471fbc21e3b2bdba99798c0b7144c3d6a92819c29e4ac6449a6db83fdd55ba81d3b2e3f8ca6c991ee6c117ddc490a88ae210e5bc07ab8 SHA512 99297f14f6716ada7a29b204723a0c951002529362a22f695b3647517462f43af563ea55467985dda3e21d79a14d46b84dbc9b22a8c0751fba49257e30f70a7f
+DIST dlx-1.5.20.zip 137039 BLAKE2B 99dbb2e5bcd89b3e9f3d8edc2fe7e7cc0a59f870f597a40a61a993b95d8b27c4f95b8d0490fdbcbc15693040d6e3abdfb8b0062e109916f5299c3da3c203d755 SHA512 5c832c2a486a82574ae03ec0cb4e30bfec74ef968658a38fbd896a1383dcdc558501baef7cbbdf99df453ba2840622d16c1619f9c5fe34b6cd058a7718bd3790
diff --git a/app-emulation/dlx/dlx-1.5.20.ebuild b/app-emulation/dlx/dlx-1.5.20.ebuild
new file mode 100644
index 000000000000..30e768088a51
--- /dev/null
+++ b/app-emulation/dlx/dlx-1.5.20.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="DLX Simulator"
+HOMEPAGE="https://www.davidviner.com/dlx"
+SRC_URI="https://www.davidviner.com/zip/dlx/dlx.zip -> ${P}.zip"
+S=${WORKDIR}/dlx
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+src_compile() {
+ # CXX not used
+ emake CC="$(tc-getCC)" LINK="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin masm mon dasm
+ dodoc README.txt MANUAL.TXT
+}