summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-05 05:20:43 +0000
committerSam James <sam@gentoo.org>2023-12-05 06:39:12 +0000
commit0559a5198d76cefe1bbd789765ae48e7e2a2e1bd (patch)
tree2c7ce4c4aa851c235291ecc062a24a3fcd4d1378
parentdev-libs/libx86emu: Stabilize 3.5-r1 amd64, #918980 (diff)
downloadgentoo-0559a5198d76cefe1bbd789765ae48e7e2a2e1bd.tar.gz
gentoo-0559a5198d76cefe1bbd789765ae48e7e2a2e1bd.tar.bz2
gentoo-0559a5198d76cefe1bbd789765ae48e7e2a2e1bd.zip
dev-perl/Tk: drop 804.36.0
Bug: https://bugs.gentoo.org/919212 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/Tk/Tk-804.36.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-perl/Tk/Tk-804.36.0.ebuild b/dev-perl/Tk/Tk-804.36.0.ebuild
deleted file mode 100644
index 7cd1c64bdd66..000000000000
--- a/dev-perl/Tk/Tk-804.36.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=SREZIC
-DIST_VERSION=804.036
-DIST_EXAMPLES=("examples/*")
-inherit perl-module virtualx
-
-DESCRIPTION="A Perl Module for Tk"
-
-LICENSE+=" tcltk BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="
- media-libs/freetype
- >=media-libs/libpng-1.4:0
- virtual/jpeg
- x11-libs/libX11
- x11-libs/libXft"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-804.034-xorg.patch
-)
-
-PERL_RM_FILES=( "t/pod.t" )
-
-src_prepare() {
- myconf=( X11ROOT="${EPREFIX}"/usr XFT=1 -I"${EPREFIX}"/usr/include/ -l"${EPREFIX}"/usr/$(get_libdir) )
- mydoc="ToDo VERSIONS"
-
- perl-module_src_prepare
- # fix detection logic for Prefix, bug #385621
- sed -i -e "s:/usr:${EPREFIX}/usr:g" myConfig || die
- # having this around breaks with perl-module and a case-IN-sensitive fs
- rm build_ptk || die
-
- # Remove all bundled libs, fixes #488194
- local BUNDLED="PNG/libpng \
- PNG/zlib \
- JPEG/jpeg"
-
- # Move files required for tests temporarily
-
- mkdir -p "${T}/stash" || die "can't create temporary stash"
- mv "${S}/JPEG/jpeg/testimg.jpg" "${T}/stash/testimg.jpg" || die "can't move testimg.jpg"
-
- for dir in ${BUNDLED}; do
- einfo "Removing bundled: ${dir}"
- rm -r "${S}/${dir}" || die "Can't remove bundle"
- # Makefile.PL can copy files to ${S}/${dir}, so recreate them back.
- mkdir -p "${S}/${dir}" || die "Can't restore bundled dir"
- sed -i "\#^${dir}#d" "${S}"/MANIFEST || die 'Can not remove bundled libs from MANIFEST'
- done
-
- # Restore test files
- mv "${T}/stash/testimg.jpg" "${S}/JPEG/jpeg/testimg.jpg" || die "can't restore testimg.jpg"
-}
-
-src_test() {
- virtx perl-module_src_test
-}