summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-15 19:23:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-15 19:23:45 +0200
commit057a81ccc9218b2773779d72a83cfb1cc9b38ac8 (patch)
treeb702086749dda21cc99a23058154be50602d3cf0
parentdev-tex/tex4ht: Fix segmentation fault in tex4ht binary (diff)
downloadgentoo-057a81ccc9218b2773779d72a83cfb1cc9b38ac8.tar.gz
gentoo-057a81ccc9218b2773779d72a83cfb1cc9b38ac8.tar.bz2
gentoo-057a81ccc9218b2773779d72a83cfb1cc9b38ac8.zip
dev-python/jupyterlab-server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.23.0.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index da15a1aec471..a53e50918faf 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1,2 +1 @@
-DIST jupyterlab_server-2.23.0.tar.gz 71812 BLAKE2B 4d1cd379e9864f16a463f630b2b30aa18b88c9e71ea591d396b15834b08d567b3dbd0e6de637f975d230e17987f49eac3917ce2cf951dfd493ee75e612b3b46e SHA512 cb5ae1125487c79fa9d54201e0512fac9ff3f95022eafacd0bf46cb853bbeafe74eff767137ecb5559713cd8baf721f7fbc41869dde9ef28c480197a4158967a
DIST jupyterlab_server-2.25.0.tar.gz 72251 BLAKE2B aac9191493833aea1dbd2b2b85365bab2bfbf06576c853668cc94d62b03b8cabaabc2df8c76ae57c8d76d55ddf646bdf51de00f682cc5b4b27252d5bd409bc61 SHA512 b97a1e5da8f30e83971be152a39c5a6553e6a589000f4848feb7777561b018b310f445853825215cfdb823666d73d4b117ed8914138c8a319035dac893f85951
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.23.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.23.0.ebuild
deleted file mode 100644
index 265984ae432d..000000000000
--- a/dev-python/jupyterlab-server/jupyterlab-server-2.23.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=hatchling
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyterlab/jupyterlab_server/
- https://pypi.org/project/jupyterlab-server/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
- >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.28[${PYTHON_USEDEP}]
- >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
- <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter-server[${PYTHON_USEDEP}]
- <dev-python/openapi-core-0.17[${PYTHON_USEDEP}]
- >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
- dev-python/pytest-jupyter[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-# TODO: package autodoc_traits
-#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
-
-python_test() {
- local EPYTEST_IGNORE=(
- tests/test_translation_api.py
- )
-
- EPYTEST_DESELECT=(
- # Fails if terminal not available
- tests/test_labapp.py::test_page_config
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_tornasync.plugin
-}