summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-16 12:49:59 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-16 12:59:01 +0200
commit059cc5d6a7a5a6748dff01ce355c47dde1ccde69 (patch)
treedfeeff918d74702f4cc64b149a46570ebd8fdfc0
parentdev-ml/labltk: bump to 8.06.9 (diff)
downloadgentoo-059cc5d6a7a5a6748dff01ce355c47dde1ccde69.tar.gz
gentoo-059cc5d6a7a5a6748dff01ce355c47dde1ccde69.tar.bz2
gentoo-059cc5d6a7a5a6748dff01ce355c47dde1ccde69.zip
net-libs/xrootd: remove old
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-4.12.0.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index c553b4791b21..cd7117a12cf7 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,3 +1,2 @@
-DIST xrootd-4.12.0.tar.gz 2564041 BLAKE2B 6ea9c379aa482c81279168baa3e1381e880d34014fb3516c96961da64d54faf649295f024313ece445df9a62b6b5c818b7aa8a987025d3cd969188de072648c9 SHA512 5338c4fb5461918473dd4f41f4d29fae09a8fc6a9e2d8f00bb74d929dc5396fef73643462d1a4f1ba71ffe5cf92a1695a167ca3a766c674a9377dcf99aaa1778
DIST xrootd-4.12.4.tar.gz 2577360 BLAKE2B f2e4413bcbf02dccb1ac7b0ceec8fbc2bb8b1de838cd9753c9d61f76fc2d68e845a41075b63a4afe56b1a434cf89ecf4f4b8571fa9ae866a19e6bcadcc5dcd9b SHA512 8cbc5e5f270f39c48b7c75a15e2721ebb793f13419608834777f39bc0ee7dd8c4fad481367f997172dae5029d9e5e4e9d7870843bd5c9957fa9fe439592c4364
DIST xrootd-5.0.2.tar.gz 2764503 BLAKE2B 35bc642d3601738135ff24a77f9bc8795568553856284ebe80d90315039d04109353d2e00310f8b8168f6b1176ee295c9116a7e6adaff33ca23383da9deecf17 SHA512 e58b5484c0fa9f83643e252eb8228f2061130b4f97964283a6adb8a81560841f3d44814572136023d944be6bdd97cff551e75bbfb04e6c9aafaa779ecb051255
diff --git a/net-libs/xrootd/xrootd-4.12.0.ebuild b/net-libs/xrootd/xrootd-4.12.0.ebuild
deleted file mode 100644
index 3974f5488b24..000000000000
--- a/net-libs/xrootd/xrootd-4.12.0.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit cmake-utils python-single-r1
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fuse http kerberos python readline ssl test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="acct-group/xrootd
- acct-user/xrootd
- sys-libs/zlib
- fuse? ( sys-fs/fuse:= )
- kerberos? ( virtual/krb5 )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:0= )
- ssl? ( dev-libs/openssl:0= )
-"
-DEPEND="${CDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen[dot]
- python? ( dev-python/sphinx )
- )
- test? ( dev-util/cppunit )
-"
-RDEPEND="${CDEPEND}
- dev-lang/perl
-"
-REQUIRED_USE="
- http? ( kerberos ssl )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
-
-# xrootd plugins are not intended to be linked with,
-# they are to be loaded at runtime by xrootd,
-# see https://github.com/xrootd/xrootd/issues/447
-QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so"
-
-pkg_setup() {
- use python && python_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CRYPTO=$(usex ssl)
- -DENABLE_FUSE=$(usex fuse)
- -DENABLE_HTTP=$(usex http)
- -DENABLE_KRB5=$(usex kerberos)
- -DENABLE_PYTHON=$(usex python)
- -DENABLE_READLINE=$(usex readline)
- -DENABLE_TESTS=$(usex test)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- doxygen Doxyfile || die
- if use python; then
- emake -C bindings/python/docs html
- fi
- fi
-}
-
-src_install() {
- use doc && HTML_DOCS=( doxydoc/html/. )
- dodoc docs/ReleaseNotes.txt
- cmake-utils_src_install
- find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
-
- # base configs
- insinto /etc/xrootd
- doins packaging/common/*.cfg
-
- fowners root:xrootd /etc/xrootd
- keepdir /var/log/xrootd
- fowners xrootd:xrootd /var/log/xrootd
-
- local i
- for i in cmsd frm_purged frm_xfrd xrootd; do
- newinitd "${FILESDIR}"/${i}.initd ${i}
- done
- # all daemons MUST use single master config file
- newconfd "${FILESDIR}"/xrootd.confd xrootd
-
- if use python; then
- python_optimize "${D}/$(python_get_sitedir)"
-
- if use doc; then
- docinto python
- docompress -x "/usr/share/doc/${PF}/python/html"
- dodoc -r bindings/python/docs/build/html
- fi
- if use examples; then
- docinto python
- dodoc -r bindings/python/examples
- fi
- fi
-}