summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-16 04:58:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-16 04:58:52 +0100
commit05b3378ba9bac057250d79d0a34bf58d946955c3 (patch)
treede92c1e9f7749e374b93eec940073767269217d7
parentdev-python/cfn-lint: Bump to 0.83.3 (diff)
downloadgentoo-05b3378ba9bac057250d79d0a34bf58d946955c3.tar.gz
gentoo-05b3378ba9bac057250d79d0a34bf58d946955c3.tar.bz2
gentoo-05b3378ba9bac057250d79d0a34bf58d946955c3.zip
dev-python/fonttools: Bump to 4.44.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.44.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 03084acbcc0c..1dbea020632f 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,3 +1,4 @@
DIST fonttools-4.43.1.gh.tar.gz 3770153 BLAKE2B d5abb086605126bbb814f4631e1da412f0f98f678274097340516bc0c9e8572039778ef3acd1fee1943e9bf431b1120de1a6809d64e64a77d81af63f61a49755 SHA512 5c505098c2f82421ef5daa0c3bad03910e978dc2dba17a80c9dcd27d5692822ae3579f1d6bc2184e80dcded0dcf61f4a859cc1b5951f07f3467197c21954ac38
DIST fonttools-4.44.0.gh.tar.gz 3771969 BLAKE2B 26a9bef8e6f5595bca8a27ca1b46cfa16c2bb5741d82fdf203be163510f1380b76307e3fb4921200b49d422ef602134f399a502087dd4dc6ff959871deb92ef6 SHA512 c665e0cae9b486f5373eb775d3a38a2b5a794ce64a112cf83f1e86d1433481944c8db1b30a5c6ed047f3639ebe63ddcad800a871a9289d186be67c9c8c0afa0a
DIST fonttools-4.44.1.gh.tar.gz 3772404 BLAKE2B 75ea507c234846e26d3e1693c3ae8c23ac45c1ed0496958cf9589928e2918b496038f8729c7418080adf64e94a1ae0cb156e2b5925b69885660225daa8596359 SHA512 574dc1661c5b6cd63d70f4195f06e2dc6fe75bf84912720390314c2b3ed5edaaf05cc8879520b356857aef4cfd23ef2ae4c42c5cf5048359be63f757644d95b2
+DIST fonttools-4.44.3.gh.tar.gz 3775926 BLAKE2B fcc482ffa6163f895cf6ea8721dae3ce85beea3bbf3d19c30e5f2a681356e66ff5ffc3ee4b228244eaebbcc76e397ec1e841ed3f96fda2eb2561e26f0b90a174 SHA512 cedac35c1273d95785095678a90aef58307b5c66bcd3c2e4f72f6642412265e783afc5e0e1e4cff77ceb31f1f5406ae24d130856c41821998da94e088628823e
diff --git a/dev-python/fonttools/fonttools-4.44.3.ebuild b/dev-python/fonttools/fonttools-4.44.3.ebuild
new file mode 100644
index 000000000000..eb45479d5b14
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.44.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest Tests fontTools \
+ -p rerunfailures --reruns=5 \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal ||
+ die "Tests failed with ${EPYTHON}"
+}