summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 05:58:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 08:00:57 +0200
commit05c7aabf0d24b4aabc7a852437ed265503759f4b (patch)
tree66450511259cde2d5d92ba545c8cee75dd5aad9c
parentdev-python/stripe: Bump to 3.2.0 (diff)
downloadgentoo-05c7aabf0d24b4aabc7a852437ed265503759f4b.tar.gz
gentoo-05c7aabf0d24b4aabc7a852437ed265503759f4b.tar.bz2
gentoo-05c7aabf0d24b4aabc7a852437ed265503759f4b.zip
dev-python/pkginfo: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pkginfo/pkginfo-1.8.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pkginfo/pkginfo-1.8.2-r1.ebuild b/dev-python/pkginfo/pkginfo-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..c41b1fb5753c
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.8.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs