summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-07 00:28:37 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-07 00:29:37 -0700
commit05ca9e6952e072b0b561d627488ada6f72131e4c (patch)
tree70dc6bf604d29882853fd29e1d5586f378bb5dab
parentnet-dns/dnscrypt-proxy: drop 2.0.16 (diff)
downloadgentoo-05ca9e69.tar.gz
gentoo-05ca9e69.tar.bz2
gentoo-05ca9e69.zip
net-dns/dnscrypt-proxy: add 2.0.17 pre-release
This one is compatible with go-1.11 Closes: https://bugs.gentoo.org/665422 Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17_pre20180903.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 17454adf09dc..25ffa0e6c664 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1 +1,2 @@
DIST dnscrypt-proxy-2.0.16.tar.gz 3770249 BLAKE2B e6dc40ec503cff11e4deec1a243875fff42ec7ecba8c7c3552b69322d405c762fa152e7e9417baf944e2a476715f00813a305c20db583970520d35acd378f1d4 SHA512 f138df20560dd440a2ed390c1468d630191ae7b0e50521b4dde3fa7ef4377c3ae6409e8c547858bace53216c84aeeea6794305546b9ff87832f704c160c6782f
+DIST dnscrypt-proxy-da5ee45b8ceb9233f4bc21b2a5f1eb7c875947cc.tar.gz 3266257 BLAKE2B bc724b56ef75faf1e2416e81fe3e68947f1581ef1c85575b8c7c5bde721f41f32604835678923dd12654b23a2c97a7e84d598eb8c7a7f553cb59c998141ff19c SHA512 cd23bc4cee7a1d9337ad5a41cf49c5603d9bfb8b7a0458532de68df35f8bd1bb75c39c069dc692506673bdba485e360b23712e997072ed86b541597aa3ea9b12
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17_pre20180903.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17_pre20180903.ebuild
new file mode 100644
index 000000000000..c9ee2a53186f
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17_pre20180903.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_COMMIT="da5ee45b8ceb9233f4bc21b2a5f1eb7c875947cc"
+EGO_PN="github.com/jedisct1/${PN}"
+MY_P="${PN}-${EGIT_COMMIT}"
+
+inherit fcaps golang-build systemd user
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="pie test"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup dnscrypt-proxy
+ enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
+}
+
+src_prepare() {
+ default
+ # Create directory structure suitable for building
+ mkdir -p "src/${EGO_PN%/*}" || die
+ mv "${PN}" "src/${EGO_PN}" || die
+ mv "vendor" "src/" || die
+}
+
+src_configure() {
+ EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
+}
+
+src_compile() {
+ ego_pn_check
+ GOPATH="${WORKDIR}/${MY_P}:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_test() {
+ ego_pn_check
+ GOPATH="${WORKDIR}/${MY_P}:$(get_golibdir_gopath)" \
+ go test -v -work -x "${EGO_PN}"
+}
+
+src_install() {
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+ doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ insinto /usr/share/dnscrypt-proxy
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53"
+ ewarn "please do one the following:"
+ ewarn "1) re-enable 'filecaps'"
+ ewarn "2) change port to > 1024"
+ ewarn "3) configure to run ${PN} as root (not recommended)"
+ ewarn
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v} == 1.* ]] ; then
+ elog "Version 2 is a complete rewrite of ${PN}"
+ elog "please clean up old config/log files"
+ elog
+ fi
+ if [[ ${v} == 2.* ]] ; then
+ elog "As of version 2.0.12 of ${PN} runs as an 'dnscrypt-proxy' user/group"
+ elog "you can remove obsolete 'dnscrypt' accounts from the system"
+ elog
+ fi
+ done
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Using systemd socket activation may cause issues with speed"
+ elog "latency and reliability of ${PN} and is discouraged by upstream"
+ elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+ elog "It is disabled by default for new installations"
+ elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}