summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-25 10:01:58 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-25 10:02:16 -0700
commit05f1a2d074df8ebd956a11cce984be27d4310077 (patch)
treee96c322b05c87b71d49dabe7efc185680d875ee6
parentdev-python/pypy-exe-bin: Extend to arm64 and ppc64le (diff)
downloadgentoo-05f1a2d0.tar.gz
gentoo-05f1a2d0.tar.bz2
gentoo-05f1a2d0.zip
sys-apps/mount-idmapped: new package, add 0.0_pre20220825
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-apps/mount-idmapped/Manifest1
-rw-r--r--sys-apps/mount-idmapped/metadata.xml8
-rw-r--r--sys-apps/mount-idmapped/mount-idmapped-0.0_pre20220825.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/mount-idmapped/Manifest b/sys-apps/mount-idmapped/Manifest
new file mode 100644
index 000000000000..e548f09d8534
--- /dev/null
+++ b/sys-apps/mount-idmapped/Manifest
@@ -0,0 +1 @@
+DIST mount-idmapped-0.0_pre20220825.gh.tar.gz 15022 BLAKE2B f31077a6dc1f1da1797a4b1b233d74a85d268a768f1bd6691a02f8aecaa38ae669eaa214d5fbf116277206b367a0c02a820847c277aee5bbe4a50ec023fa5dea SHA512 9b1ea2927f60f0c807310da9594b1fc489e64c3e322122fbeaa5d18be46a87787cc5458ecc0c90164ff8fdb80464e65d27942a2d9d280b4b55b6a090685ef874
diff --git a/sys-apps/mount-idmapped/metadata.xml b/sys-apps/mount-idmapped/metadata.xml
new file mode 100644
index 000000000000..bd6443d4a375
--- /dev/null
+++ b/sys-apps/mount-idmapped/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/mount-idmapped/mount-idmapped-0.0_pre20220825.ebuild b/sys-apps/mount-idmapped/mount-idmapped-0.0_pre20220825.ebuild
new file mode 100644
index 000000000000..afb4f187870b
--- /dev/null
+++ b/sys-apps/mount-idmapped/mount-idmapped-0.0_pre20220825.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+COMMIT_HASH="71a9e8bae308aed5aa59e02875122a728cdb5dba"
+
+DESCRIPTION="A tiny tool to allow the creation of idmapped mounts"
+HOMEPAGE="https://github.com/brauner/mount-idmapped"
+SRC_URI="https://github.com/brauner/mount-idmapped/archive/${COMMIT_HASH}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=sys-kernel/linux-headers-5.12
+"
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ "${CC}" ${CFLAGS} ${LDFLAGS} ${PN}.c -o "${PN}" || die
+}
+
+src_install() {
+ local -a DOCS=(
+ README.md
+ )
+ default
+ dobin ${PN}
+}