summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-10 08:22:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-10 08:58:03 +0100
commit061ad887e870429b3823e5c298353e83dd666eff (patch)
tree855e6682dc44390f5e62af28213cbdc9e91addb2
parentnet-firewall/firewalld: Stabilize 1.0.3 ppc64, #833032 (diff)
downloadgentoo-061ad887.tar.gz
gentoo-061ad887.tar.bz2
gentoo-061ad887.zip
dev-python/botocore: Bump to 1.23.52
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.52.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 22c1b531eec8..2a14f5c96b63 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.23.48.tar.gz 8757876 BLAKE2B e70a1aa1fdbeab5246640d9e5fc26ac6853
DIST botocore-1.23.49.tar.gz 8758361 BLAKE2B 5e53366fdd705e81af6752665f3078e26d55460bc2e3644fa030f6b3a4485bd504c445ac15d6b6abcdb164d6c93f33fe8a596d5eb8e7f85c10363cd93a3d3e58 SHA512 2450752613a815a67f007a23371e0349a2ebaa991f3b48062bab5ed5736fa11255e206a20cc71a2477b65673f689c5447229a9e0c14358ffcd322e1f55971a86
DIST botocore-1.23.50.tar.gz 8758107 BLAKE2B ac43af21c46168bc0c14f3afe6afb06e1e33e09af9c0f62bc6331f6bb2240563e137dcf23381ec0e4ed97f79e3475a70ae73ded969b0c9f954f01361504134ee SHA512 64230e9d6d4b4916fcbe8d2fdbba2ee0575a85de56160518e8ad48f2f1566f7cec0667cd9bd53f2afa514f5f6e341cc681b2830a43ac82e3356c1e82a49e2c7a
DIST botocore-1.23.51.tar.gz 8763657 BLAKE2B f8abe69785f50c244073a791c124a51c8f92e67b0245465e878f13449b999585849e88f706392709caea26d69fb3850b9749cc9a57ea5c1df62f08008b8d56fc SHA512 e54cf59656bd5144b1f85d4ea57eaefd5ea4ac570b877771e06df62f442e61b2f239c1a4dd083c26cb75905d139cf681dcba67e3d89d2af0b99e416e65141917
+DIST botocore-1.23.52.tar.gz 8765120 BLAKE2B e45fc2269a527d4e056f97cb81bf13982bbcde887179ec00259cfd5f78b6bd50b10c4d9e2bc09739e2f58d1d1d602902d9e2355b42f83b7736fdf6b3bc269fab SHA512 ff18c7b8779c622cab26ccb74014c7779a3d117cdc0236df0f0048b9e2b2047d703ea3286554dfef25514b73bddcfbd6875ff6f4147c760e39293190fc2c51c0
diff --git a/dev-python/botocore/botocore-1.23.52.ebuild b/dev-python/botocore/botocore-1.23.52.ebuild
new file mode 100644
index 000000000000..79a1cd5da0e2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.52.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit}
+}