summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 05:51:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 05:51:40 +0200
commit061f9fa3bdcf1930a4ab134684969fa8722a6bb8 (patch)
tree4fb44498de534e63ce940387b0a3b88d8ec594fa
parentdev-python/django-crispy-forms: Bump to 2.1 (diff)
downloadgentoo-061f9fa3bdcf1930a4ab134684969fa8722a6bb8.tar.gz
gentoo-061f9fa3bdcf1930a4ab134684969fa8722a6bb8.tar.bz2
gentoo-061f9fa3bdcf1930a4ab134684969fa8722a6bb8.zip
dev-python/crispy-bootstrap5: Reformat
Wanted to add py3.12 but it's broken. Obviously not tested. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
index a1e440cc9f5b..b04b976d40a0 100644
--- a/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
@@ -4,26 +4,35 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
+
inherit distutils-r1
DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/
https://pypi.org/project/crispy-bootstrap5/
"
-SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RDEPEND="dev-python/django-crispy-forms[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- dev-python/pytest-django[${PYTHON_USEDEP}]
-)"
+RDEPEND="
+ dev-python/django-crispy-forms[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+)