summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-09-25 00:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-10-02 13:45:07 -0400
commit0623ba1f0b28c7126996383d3320490bb5285729 (patch)
treef819bc33e393b1ad70ecd60836632c909b4cc82e
parentdev-lang/julia-bin: version bump to 1.5.2 (diff)
downloadgentoo-0623ba1f.tar.gz
gentoo-0623ba1f.tar.bz2
gentoo-0623ba1f.zip
app-i18n/tomoe: Fix building with glibc 2.32.
Closes: https://bugs.gentoo.org/713210 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--app-i18n/tomoe/files/tomoe-glibc-2.32.patch11
-rw-r--r--app-i18n/tomoe/tomoe-0.6.0-r6.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/app-i18n/tomoe/files/tomoe-glibc-2.32.patch b/app-i18n/tomoe/files/tomoe-glibc-2.32.patch
new file mode 100644
index 000000000000..5d296cdcdd39
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-glibc-2.32.patch
@@ -0,0 +1,11 @@
+--- /lib/tomoe-xml-parser.c
++++ /lib/tomoe-xml-parser.c
+@@ -441,7 +441,7 @@
+ f = fopen (filename, "rb");
+ if (!f) {
+ g_warning ("failed to open dictionary file %s: %s", filename,
+- sys_errlist[errno]);
++ strerror(errno));
+ }
+ g_return_val_if_fail (f, FALSE);
+
diff --git a/app-i18n/tomoe/tomoe-0.6.0-r6.ebuild b/app-i18n/tomoe/tomoe-0.6.0-r6.ebuild
index 00b0c32111b1..ad6822db39c6 100644
--- a/app-i18n/tomoe/tomoe-0.6.0-r6.ebuild
+++ b/app-i18n/tomoe/tomoe-0.6.0-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2006-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -39,6 +39,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
"${FILESDIR}"/${PN}-export-symbols.patch
+ "${FILESDIR}"/${PN}-glibc-2.32.patch
"${FILESDIR}"/${PN}-glib-2.32.patch
"${FILESDIR}"/${PN}-ruby19.patch
)