summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-18 17:42:59 +0100
committerDavid Seifert <soap@gentoo.org>2023-03-18 17:42:59 +0100
commit063129fdf7c4a1d516c3c08fd3263f25901bcc89 (patch)
tree30bf246f9122e15b19bdce5d82b83ae103689212
parentdev-java/core-specs-alpha: treeclean (diff)
downloadgentoo-063129fdf7c4a1d516c3c08fd3263f25901bcc89.tar.gz
gentoo-063129fdf7c4a1d516c3c08fd3263f25901bcc89.tar.bz2
gentoo-063129fdf7c4a1d516c3c08fd3263f25901bcc89.zip
www-misc/wsmake: treeclean
Closes: https://bugs.gentoo.org/726094 Closes: https://bugs.gentoo.org/806384 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--profiles/package.mask7
-rw-r--r--www-misc/wsmake/Manifest1
-rw-r--r--www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch29
-rw-r--r--www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch33
-rw-r--r--www-misc/wsmake/metadata.xml5
-rw-r--r--www-misc/wsmake/wsmake-0.6.4-r1.ebuild44
6 files changed, 0 insertions, 119 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 0b45ed3496d2..d49117cf9362 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -288,13 +288,6 @@ acct-group/jabber
# Commands trigger an assertion and crashes, bug #892487
=sys-fs/lvm2-2.03.18
-# Michał Górny <mgorny@gentoo.org> (2023-01-26)
-# Unmaintained. Last release in 2003. The package fails to install
-# since Aug 2021 and while a fix would be trivial, there does not seem
-# to have been any interest in it during that period.
-# Removal on 2023-02-25. Bug #806384.
-www-misc/wsmake
-
# Michał Górny <mgorny@gentoo.org> (2023-01-25)
# Unmaintained. Multiple build failure bugs reported. This version
# predates 2008.
diff --git a/www-misc/wsmake/Manifest b/www-misc/wsmake/Manifest
deleted file mode 100644
index 8b30b6ff26f3..000000000000
--- a/www-misc/wsmake/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST wsmake-0.6.4.tar.bz2 351688 BLAKE2B 4e810b1b5f697bc8a7bbb27a4023ff50f90fbcab5f9bf7890277ebb95d5fbf90cfaad51f181c4a76bd532f802fd4eaf07dbab6757a15ee242f80dbef19ce0b08 SHA512 0f5d125053222c624f9c19f4147f0d97311acb11050e09112ae7b13175ea64d0ba75942c5772e2ffe12d2913cea370ed663d7cb649eef67e0f8379775a3459c4
diff --git a/www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch b/www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch
deleted file mode 100644
index 420bbb61b030..000000000000
--- a/www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/libwsmake/wsUtil.cpp
-+++ b/libwsmake/wsUtil.cpp
-@@ -710,13 +710,13 @@
- }
- }
-
--void std::__wsmake_print_it(FILE *out, const char *output, const va_list *ap)
-+void std::__wsmake_print_it(FILE *out, const char *output, va_list *ap)
- {
- if(__wsmake_quiet) return;
-
- vfprintf(out,output,*ap);
- //BV: this does not compile: va_end((void*&)*ap);
-- va_end((char*&)*ap);
-+ va_end(*ap);
- }
-
- #ifdef DEBUG
---- a/libwsmake/wsUtil.h
-+++ b/libwsmake/wsUtil.h
-@@ -77,7 +77,7 @@
- void __wsmake_print_error(const char *, ...);
- void __wsmake_print(const char *, ...);
- void __wsmake_print(int, const char *, ...);
-- void __wsmake_print_it(FILE *, const char *, const va_list *);
-+ void __wsmake_print_it(FILE *, const char *, va_list *);
- }
-
- #endif /* __WSUTIL_H__ */
diff --git a/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch b/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
deleted file mode 100644
index 9028c0695546..000000000000
--- a/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=251745
-https://sourceforge.net/tracker/index.php?func=detail&aid=2520894&group_id=5982&atid=105982
-
---- a/libwsmake/wsSubTag.cpp
-+++ b/libwsmake/wsSubTag.cpp
-@@ -22,6 +22,7 @@
- ***********************************************************************/
- #include <cstdio>
- #include <cstring>
-+#include <cstdlib>
-
- #include <unistd.h>
- #ifdef HAVE_SYS_WAIT_H
---- a/libwsmake/wsWebPage.cpp
-+++ b/libwsmake/wsWebPage.cpp
-@@ -23,6 +23,7 @@
- #include <cassert>
- #include <cerrno>
- #include <ctime>
-+#include <cstdlib>
-
- #include "wsmake.h"
-
---- a/libwsmake/wsUtil.cpp
-+++ b/libwsmake/wsUtil.cpp
-@@ -28,6 +28,7 @@
- #include <cassert>
- #include <cerrno>
- #include <cstring>
-+#include <cstdlib>
-
- #ifdef HAVE_UTIME_H
- #include <utime.h>
diff --git a/www-misc/wsmake/metadata.xml b/www-misc/wsmake/metadata.xml
deleted file mode 100644
index 85e4ed814fa2..000000000000
--- a/www-misc/wsmake/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/www-misc/wsmake/wsmake-0.6.4-r1.ebuild b/www-misc/wsmake/wsmake-0.6.4-r1.ebuild
deleted file mode 100644
index a0bf513caf90..000000000000
--- a/www-misc/wsmake/wsmake-0.6.4-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Website pre-processor features tag substitution and page ordering"
-HOMEPAGE="https://sourceforge.net/projects/wsmake/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2+ Artistic"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE="examples"
-
-PATCHES=(
- "${FILESDIR}"/${P}-bv.diff
- "${FILESDIR}"/${P}-gcc43.patch # 251745
- "${FILESDIR}"/${P}-fix-const-va_list.patch
-)
-
-src_unpack() {
- default
-
- cd "${S}"/doc || die
- tar -cf examples.tar examples || die
-}
-
-src_configure() {
- tc-export CXX
- default
-}
-
-src_install() {
- default
- dodoc doc/manual.txt
-
- if use examples; then
- rm -r doc/examples/CVS || die
- dodoc -r doc/examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}