summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-15 00:35:01 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-15 00:35:07 +0100
commit064291d970dc502eb775013b2001f4714b30516c (patch)
tree52c9620a17d8d2b7027167cbfd57f80b593eadf1
parentdev-libs/libxmlb: Removed old (diff)
downloadgentoo-064291d970dc502eb775013b2001f4714b30516c.tar.gz
gentoo-064291d970dc502eb775013b2001f4714b30516c.tar.bz2
gentoo-064291d970dc502eb775013b2001f4714b30516c.zip
dev-libs/libxmlb: Fixed python detection
Closes: https://bugs.gentoo.org/765454 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.15.ebuild8
-rw-r--r--dev-libs/libxmlb/libxmlb-0.2.1.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-libs/libxmlb/libxmlb-0.1.15.ebuild b/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
index 68409989938f..80a864311d25 100644
--- a/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
+++ b/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit meson python-any-r1
@@ -31,11 +31,11 @@ DEPEND="
"
BDEPEND="
+ ${PYTHON_DEPS}
>=dev-util/meson-0.47.0
virtual/pkgconfig
introspection? (
$(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
)
"
@@ -44,7 +44,7 @@ python_check_deps() {
}
pkg_setup() {
- use introspection && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_configure() {
diff --git a/dev-libs/libxmlb/libxmlb-0.2.1.ebuild b/dev-libs/libxmlb/libxmlb-0.2.1.ebuild
index 30f41ec4d836..03845174fc31 100644
--- a/dev-libs/libxmlb/libxmlb-0.2.1.ebuild
+++ b/dev-libs/libxmlb/libxmlb-0.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit meson python-any-r1
@@ -31,11 +31,11 @@ DEPEND="
"
BDEPEND="
+ ${PYTHON_DEPS}
>=dev-util/meson-0.47.0
virtual/pkgconfig
introspection? (
$(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
)
"
@@ -44,7 +44,7 @@ python_check_deps() {
}
pkg_setup() {
- use introspection && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_configure() {