summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-01-18 12:44:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-01-18 12:44:51 -0600
commit064c0ec71ca34af67e60b64a97ff503ed1a80221 (patch)
tree98fe3598d846c25b2a764912e612492986a2d538
parentmedia-libs/libwmf: do not install .la files (diff)
downloadgentoo-064c0ec71ca34af67e60b64a97ff503ed1a80221.tar.gz
gentoo-064c0ec71ca34af67e60b64a97ff503ed1a80221.tar.bz2
gentoo-064c0ec71ca34af67e60b64a97ff503ed1a80221.zip
www-apps/icingaweb2: 2.9.4 cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.9.4.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index e07dcc070afd..07fbe2f2da87 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1 @@
-DIST icingaweb2-2.9.4.tar.gz 12314780 BLAKE2B 3ecce619c27dc560b8da3155d008c3f3ab07b7ea0e6a66d0cbc3886becee8f1cf2f99e2cb7d79e2776be09b3bda82da2574d280dc26e41ea8d2ac568354c694a SHA512 77e446c9b48e9db7817fd6a46a6be9f57dfb21278066cce70f6c85d04f04200ec862c3c29c93d62fa3d0468973ddfc04eac5aa957677ec02d09eb13a3aee4265
DIST icingaweb2-2.9.5.tar.gz 12313426 BLAKE2B cd044651128a560590a71a795e3ef55160db6ad8ac84cee8865258ea31747b1f1fcdc4ffab45f8e410ff7ed2d9db7c56bc3f10d856e2f0063f9608d485aa2c51 SHA512 1fa6f33c38283f0440e969ef5cd6f4aee088bfa473a7e738e70b73b19d9a512834bc6fc98b41352b8c54b3e0aa295404ab8a68d2c5009345010adfc7fe4f0abb
diff --git a/www-apps/icingaweb2/icingaweb2-2.9.4.ebuild b/www-apps/icingaweb2/icingaweb2-2.9.4.ebuild
deleted file mode 100644
index 977d8fee7bb4..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.9.4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache multilib
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-php/pecl-imagick
- pdf? ( media-gfx/imagemagick[png] )
- apache2-server? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )
- || (
- dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )
- dev-libs/icinga-php-library
- dev-libs/icinga-php-thirdparty
- acct-group/icingacmd
- acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
- if [[ -d /etc/icingaweb2 ]] ; then
- einfo "Updating existing installation ..."
- else
- einfo "Running first time setup ..."
- einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
- einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
- if use apache2 ; then
- einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
- fi
- if use nginx ; then
- einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
- fi
- fi
- einfo "All done."
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r "${S}"/*
- fperms -R a+rX "/usr/share/${PN}/public/"
- fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
- einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}