summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-11 09:36:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-11 09:42:25 +0100
commit064f083a1103c42778bd232c8bd193446b018b5d (patch)
tree2b50f701a5fc110c39d4d847ae9d839b84987fb5
parentdev-python/sphinx-autodoc-typehints: Bump to 1.25.2 (diff)
downloadgentoo-064f083a1103c42778bd232c8bd193446b018b5d.tar.gz
gentoo-064f083a1103c42778bd232c8bd193446b018b5d.tar.bz2
gentoo-064f083a1103c42778bd232c8bd193446b018b5d.zip
dev-python/qdarkstyle: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qdarkstyle/Manifest1
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-3.2.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/qdarkstyle/Manifest b/dev-python/qdarkstyle/Manifest
index d25371ae78f2..dbf4810b43bd 100644
--- a/dev-python/qdarkstyle/Manifest
+++ b/dev-python/qdarkstyle/Manifest
@@ -1,2 +1,3 @@
DIST QDarkStyle-3.1.tar.gz 698602 BLAKE2B 8c96b2dd5532c9db0c1d813fe0cf049b7cf55ef6469d2ebb21b5ea85fe6ecd23e8a247c45f45cfa674f8012a4a03ea377df8cb7efac8f13c079e2512091ecdc7 SHA512 275fe333bcf2502f8f1ef61eca3f82d8909e760e8f88a1605157c5043cb1e4cad97bbb8ddb0464ef2125c1b70f318bfa8f0106d2721d6b9862c162b5f716aa4b
+DIST QDarkStyle-3.2.1.tar.gz 681590 BLAKE2B 837b56ca96be3a03cc94840c7b70df3c6ef98d9edb7ec2d590dc82a06eef93c7d436746284e6d80e0d87212184ed67725bd40a87242ffae87f2afcaf311bb96e SHA512 435c836c9f5d61345cd9b37c151a990d1abb8c79505820cfb62ed4134f43511825a44709364bd8044e0f3acc9d63e1ccf65984334165707f9b28739f6745df50
DIST QDarkStyle-3.2.tar.gz 697274 BLAKE2B f2626ec9fdbb792f6ffaa7967da0d1175ca8f0ce5b4b279f90434ad6b926156a29a56e637a2dec01ffcba8c5e9a544adc6cf6b4c515084a786de56ae388e0e36 SHA512 d6771a02e4be7dc43b991a887080a7147465488b1f8ae9ed64a75d838ce8de6336e14074d5eabaa8a67a5ea90a30bb911a1f033bdeb999b290243bec449000a0
diff --git a/dev-python/qdarkstyle/qdarkstyle-3.2.1.ebuild b/dev-python/qdarkstyle/qdarkstyle-3.2.1.ebuild
new file mode 100644
index 000000000000..13cd2cffe65e
--- /dev/null
+++ b/dev-python/qdarkstyle/qdarkstyle-3.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="QDarkStyle"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A dark style sheet for QtWidgets application"
+HOMEPAGE="
+ https://github.com/ColinDuquesnoy/QDarkStyleSheet/
+ https://pypi.org/project/QDarkStyle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/QtPy-2.0.0[gui,${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/qtsass[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.0[gui,testlib,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "Retrieve detailed system information and report bugs upstream" dev-python/helpdev
+ optfeature "qdarkstyle.utils" dev-python/qtsass dev-python/watchdog
+}