summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-10 11:00:38 +0100
committerSam James <sam@gentoo.org>2022-04-10 11:00:50 +0100
commit066670af9c073e4dd24a9004c5c77c5fd1730d01 (patch)
treedefbc80bcfe1950009049e410edf08b119311b4a
parentapp-emulation/guestfs-tools: add 1.48.0 (diff)
downloadgentoo-066670af9c073e4dd24a9004c5c77c5fd1730d01.tar.gz
gentoo-066670af9c073e4dd24a9004c5c77c5fd1730d01.tar.bz2
gentoo-066670af9c073e4dd24a9004c5c77c5fd1730d01.zip
app-emulation/libguestfs-appliance: add 1.46.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/libguestfs-appliance/Manifest1
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.46.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/libguestfs-appliance/Manifest b/app-emulation/libguestfs-appliance/Manifest
index 70e6f7ee9cd4..a64e5add8fe3 100644
--- a/app-emulation/libguestfs-appliance/Manifest
+++ b/app-emulation/libguestfs-appliance/Manifest
@@ -1,2 +1,3 @@
DIST appliance-1.38.0.tar.xz 96537604 BLAKE2B 8b425b624dec274f2913ab9ff89cc02fea6c9244d6e3ee64f054d2a91f7959d9dbc03d55e9f5b4f5df835007581a18914b5c790f55b01c3398412ce5a7e9309d SHA512 a423fd54627ffb9c2ae05b26ad60b9089f8119a99d30612a33921a2662ba42332ad0a7a7ad6c33b7042fc02a5c4dc9b563158650c6cb4a3eaaae6b764f7d7082
DIST appliance-1.40.1.tar.xz 111566640 BLAKE2B b6ddd3b120a466ce343d67d9e058c201a78f5e605b8bbc2d47fc30c5eaaa874cc032b879a67c5f134b8fa65c58fc27893b062de0c3a21705b64766dd86df648f SHA512 2d63b2ce8850929b42ddc91518b0e2b37d13e358be94bb54899da6c310afa308d708a3443b9f3b3aa3c46f4f2079036a6a4b34027788f183c17a20b68fcf4e6e
+DIST appliance-1.46.0.tar.xz 145436856 BLAKE2B d9ed31f533a2772b0f506176b39bfdfdec1421fe4ff7934ccdb1db0cb2644d477211ec1a2d372d7e5dd0a8f278f47a39bff813b7bc4c9a038258a5f6358b4e91 SHA512 842119bdf95dbbd61328891e9bd0b557bed90ba79c6419ee18d1a79cd4a301ea6922339b9e80ac314ff3e16498e9d3c594861aebe8e0fc2db41d285eb8e5d578
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.46.0.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.46.0.ebuild
new file mode 100644
index 000000000000..a528cf39d52f
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.46.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-emulation/libguestfs and app-emulation/libguestfs (if any new release there)
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems, bug #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs || Die
+ unpack ${A}
+
+ cd appliance || die
+ dodoc README*
+ # Don't rm README.* here, at least README.fixed is needed for libguestfs, see
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1183780
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99${PN}
+}
+
+pkg_postinst() {
+ # bug #776790
+ elog "Please run . ${EROOT}/etc/profile before attempting to use this package!"
+}