summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-05-27 20:29:12 +0200
committerDavid Seifert <soap@gentoo.org>2019-05-27 20:32:37 +0200
commit067bc0dd31b97f2c8439d48e9c10bd24876880fd (patch)
treef566dec00425794559caefb53776054907bc724e
parentdev-lang/go: remove old versions (diff)
downloadgentoo-067bc0dd.tar.gz
gentoo-067bc0dd.tar.bz2
gentoo-067bc0dd.zip
dev-python/3to2: Port to EAPI 7 and add py3.7
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/3to2/3to2-1.1.1-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/3to2/3to2-1.1.1-r1.ebuild b/dev-python/3to2/3to2-1.1.1-r1.ebuild
index 4f850563c501..9297c84877eb 100644
--- a/dev-python/3to2/3to2-1.1.1-r1.ebuild
+++ b/dev-python/3to2/3to2-1.1.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
python_prepare() {
# https://bitbucket.org/amentajo/lib3to2/issues/50/testsuite-fails-with-new-python-35
@@ -23,12 +23,12 @@ python_prepare() {
sed -i -e "/test_argument_unpacking/a \\ return"\
lib3to2/tests/test_print.py || die
sed -i -e "s/Exception, err/Exception as err/" lib3to2/build.py || die
- distutils-r1_python_prepare_all
+ distutils-r1_python_prepare_all
}
python_test() {
cd "${BUILD_DIR}"/lib || die
# the standard test runner fails to properly return failure
- "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
}