summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-01-08 11:05:07 +0100
committerMichael Weber <xmw@gentoo.org>2016-01-08 11:24:22 +0100
commit069b7ddc74d77b55a0d8b0498172b7586e9b6f69 (patch)
treed12bb4220e4f68ad0e368114521db0490c4d3600
parentx11-wm/xpra: Version bump. (diff)
downloadgentoo-069b7ddc74d77b55a0d8b0498172b7586e9b6f69.tar.gz
gentoo-069b7ddc74d77b55a0d8b0498172b7586e9b6f69.tar.bz2
gentoo-069b7ddc74d77b55a0d8b0498172b7586e9b6f69.zip
app-misc/abduco: Version bump by lorem_ipsum.
Package-Manager: portage-2.2.26
-rw-r--r--app-misc/abduco/Manifest1
-rw-r--r--app-misc/abduco/abduco-0.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-misc/abduco/Manifest b/app-misc/abduco/Manifest
index 251c7889208f..3b9a3dfa5e3f 100644
--- a/app-misc/abduco/Manifest
+++ b/app-misc/abduco/Manifest
@@ -1,2 +1,3 @@
DIST abduco-0.2.tar.gz 11499 SHA256 c8b75a903b0914dd7804d57566f571f3f5efa91e46482bfb4652400156a71912 SHA512 9e6bda1779c4eff43c0f8a44857dd3beb25948c0f0bf2ff6e12bc951655e5f5ed3304794d7966b2e1cbb2c9f3917c153a1393889791a5293bd13111e15c3db11 WHIRLPOOL b76a95c21e16946eff999a148c453a44f819423fb6ab8c3903c8266c6d805d779c7232f2aa49fc0e09a19e3b6a6448b8a6a3c178266934dd1a3dcaaa4370a07c
DIST abduco-0.3.tar.gz 11978 SHA256 934bf0b9ae25fb3f71b775387b5f281bf7d175fea79c12ec28ffdbbbb95390d4 SHA512 0bbd3a52e256738d39edf8e73e43d72fd4bcf2d240f45b8287486910777310320e239e7d1abb523a37c573dc557a0e33bf5849aa34f50f261f50c27a80db7338 WHIRLPOOL 1741f3c8d47a4f745b0fa0bed79306ca2d7dba8a936c6e66c1773205809fa1cf12f33f4c9f488eaa3c31f57d21299f17ec092926539a4fd037ebf2619e0dfb85
+DIST abduco-0.4.tar.gz 14222 SHA256 bda3729df116ce41f9a087188d71d934da2693ffb1ebcf33b803055eb478bcbb SHA512 1f6df3604f5b4b59a650ccb8b6b7f9e62591154f72163350b8c8d2ffa9c392c9ebda0f958537a203e87319e275674fec6d161f18a10d49e44d0afc512c467f88 WHIRLPOOL e232bbae99cdd0c3c5b0e06f8cce73126586f9d997a03ba03720030355d603ee488df40b04343b6bfd508d2ac05dbdd2ca3bc6a62a661b140c5bd9bfc43fde12
diff --git a/app-misc/abduco/abduco-0.4.ebuild b/app-misc/abduco/abduco-0.4.ebuild
new file mode 100644
index 000000000000..250644235c88
--- /dev/null
+++ b/app-misc/abduco/abduco-0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="lightweight session manager with {de,at}tach support"
+HOMEPAGE="http://www.brain-dump.org/projects/abduco/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -e 's:^PREFIX.*:PREFIX = /usr:' \
+ -e 's/-Os//' \
+ -e '/^CC/d' \
+ -i config.mk || die
+
+ sed -e "s/VERSION/${PV}/g" \
+ -i ${PN}.1 || die
+
+ sed -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ -i Makefile || die
+
+ restore_config config.def.h
+ epatch_user
+
+ tc-export CC
+}
+
+src_test() {
+ ./testsuite.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+ doman ${PN}.1
+
+ save_config config.def.h
+}