summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-08 01:05:54 +0100
committerSam James <sam@gentoo.org>2021-09-08 01:17:36 +0100
commit069cb1d9d8574ea6640db956f81921954e0a18ed (patch)
tree2d9b836319f757dbce105536504ceccbab3fb99b
parentsys-apps/pv: add github upstream metadata (diff)
downloadgentoo-069cb1d9.tar.gz
gentoo-069cb1d9.tar.bz2
gentoo-069cb1d9.zip
sys-apps/pv: add 1.6.19
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/pv/Manifest1
-rw-r--r--sys-apps/pv/files/pv-1.6.19-stddef-include.patch17
-rw-r--r--sys-apps/pv/pv-1.6.19.ebuild64
3 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 097373f51d70..bf6b7ba788ab 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1 +1,2 @@
+DIST pv-1.6.19.tar.bz2 115130 BLAKE2B 5f8e41bb964ad8fc35c4f046b19e49a416eec4b3641d9ff77a3b9f1d04484b950629bd528c02f38eb7fd9fc1af404805a73c535fa62de4634801fb57c2e0bef8 SHA512 2ae857a8778baf853d4ad704f35afe14b37d615850f5ad52bce53ed7046dffdde720dab9b35f016739d377a062d7178cccdd0a3ccf53cf89918e3623060c9cc8
DIST pv-1.6.6.tar.bz2 109220 BLAKE2B 1cfb60e49f6301f0d990467a58013522bbc1e28e2936a1a2141918af05149b59b6cc494f290d99ee7072247b8f0e230b799cd5dae6f8aa59d116691319e952cb SHA512 cc841b4bd00e4e8fcaed97da094ebac4a11af1c3f843ce5f73d0c3ab20aca29498c6b1a224c653d40127304d8269d96f413df66b980809e9278ff9544c834a26
diff --git a/sys-apps/pv/files/pv-1.6.19-stddef-include.patch b/sys-apps/pv/files/pv-1.6.19-stddef-include.patch
new file mode 100644
index 000000000000..b28a1c8d063b
--- /dev/null
+++ b/sys-apps/pv/files/pv-1.6.19-stddef-include.patch
@@ -0,0 +1,17 @@
+https://github.com/a-j-wood/pv/pull/1
+
+From: Sam James <sam@gentoo.org>
+Date: Wed, 8 Sep 2021 01:03:29 +0100
+Subject: [PATCH] src/pv/number.c: add missing <stddef.h> include for NULL
+
+--- a/src/pv/number.c
++++ b/src/pv/number.c
+@@ -2,6 +2,8 @@
+ * Functions for converting strings to numbers.
+ */
+
++#include <stddef.h>
++
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
diff --git a/sys-apps/pv/pv-1.6.19.ebuild b/sys-apps/pv/pv-1.6.19.ebuild
new file mode 100644
index 000000000000..7acc907bef90
--- /dev/null
+++ b/sys-apps/pv/pv-1.6.19.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs plocale
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml"
+SRC_URI="https://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PLOCALES="de en fr pt_BR zh_CN"
+PLOCALE_BACKUP="en"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+# Doesn't build a library.
+QA_CONFIGURE_OPTIONS="--disable-static"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-stddef-include.patch
+)
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+
+ disable_locale() {
+ local locale=${1}
+ einfo "Disabling locale ${locale}"
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ }
+
+ plocale_for_each_disabled_locale disable_locale
+}
+
+src_configure() {
+ tc-export AR
+
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}