summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-11-06 13:52:24 +0100
committerSam James <sam@gentoo.org>2022-01-21 19:06:46 +0000
commit06ab3e0dbf833271551004bb4cef10a38c9cc880 (patch)
treedcd4d43e4563bb3cc3280c017c96bb932d9f2df8
parentlxqt-base/lxqt-notificationd: version bump to 1.0.0 (diff)
downloadgentoo-06ab3e0d.tar.gz
gentoo-06ab3e0d.tar.bz2
gentoo-06ab3e0d.zip
lxqt-base/lxqt-policykit: version bump to 1.0.0
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--lxqt-base/lxqt-policykit/Manifest1
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index 0b491ac755d8..a2524c4a0df3 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1 +1,2 @@
DIST lxqt-policykit-0.17.0.tar.xz 38272 BLAKE2B e141d0ff7a583b22ddddcde3875cf82a5215cef0c6270774b3b31e21608f16bc78dd45b3b36b8ba1fde3bbeda30b2f638a47ecf7dee1797da151cb701fecc866 SHA512 1cfd4b2d21840704e4b15ae71098e9c6f3d51031293f1fdf6e134ffee867fe4e845caaf24fbd2c107317372b90b6d415a76854977fa8f6b703e708bd09120328
+DIST lxqt-policykit-1.0.0.tar.xz 39040 BLAKE2B 0bbf68cd6ad4edf9c2553332855099317a852174baa7ef42e47c50d8a37eb8f87caa8f7698a84de9ed14d8c6afda3be93cef5113ec7019583345acdfcd82e5ad SHA512 c0d7c5ff8a5e95e74eefd094625d71603026e9d30c033e224fc4e62eba63f1bfe76ddf666eb1875a14c2c1bea3d21e4ac6d191e90bc2442f7e4e62845a63a3f0
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild
new file mode 100644
index 000000000000..35cd8f8ee90a
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}