summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 13:30:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 13:30:55 +0200
commit06ae9dfd925fbf6fe5d724c217d4a12f501d1383 (patch)
treea449f1bd45a15562faa0cd87091f89c98854fde3
parentdev-python/fakeredis: Restore python3.8 (diff)
downloadgentoo-06ae9dfd.tar.gz
gentoo-06ae9dfd.tar.bz2
gentoo-06ae9dfd.zip
sci-mathematics/z3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.8.15-r1.ebuild103
-rw-r--r--sci-mathematics/z3/z3-4.8.16.ebuild108
3 files changed, 0 insertions, 213 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index cf597f0c3e78..70d8a3764f9d 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1 @@
-DIST z3-4.8.15.tar.gz 5213633 BLAKE2B 6ca07309370f891f6ca5fa114721cb5df96e726687bf3c2310ba4963b1d1dfeec6ede62fd7a960e17e824ab8ff1e17d2af2a90d8156245ba048b04045c8f0531 SHA512 7b08dec5b035a38edc90c4c491f508fd9ed227357de94400169db53d4c59382bd6a81ae6615771023a06534a3aa92668844f0ebfcc2a3b5ef4bba957426a0c6c
-DIST z3-4.8.16.tar.gz 5223980 BLAKE2B 67bca86d48df51c9aa4fa3544fd77133c4cc429e6f77f89aa26a559e56e267b8c0891befc6a5e24be541011aac02cb0d51ef26a636c3b360a1fa4d445967da21 SHA512 385f6e1ee075b9eadb5aad338657a81f518eef382b99ce623448a630b79f5d414ebccfd1bb5e959626f0b82ef54a5f20326814ae988b5688d51578de6fb69615
DIST z3-4.8.17.tar.gz 5232392 BLAKE2B 80dbb5d48811eb6022c0d0117d1e954bae7b27ff984f24cdfbc9158eb548349f817f30ea231d1119aadeedaec63765834bff6f6d21276d0bf61c30212444f224 SHA512 95517014ec1798c2552253dd5cde6f955896ab297a4f56294f4bc6f2c5428069015f513c6eb9a090a809cfcf4cb1cc38cc83818f19b5b1051e4e6c06f973747d
diff --git a/sci-mathematics/z3/z3-4.8.15-r1.ebuild b/sci-mathematics/z3/z3-4.8.15-r1.ebuild
deleted file mode 100644
index 31cec588863f..000000000000
--- a/sci-mathematics/z3/z3-4.8.15-r1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_ECLASS=cmake
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake-multilib java-pkg-opt-2 python-single-r1
-
-DESCRIPTION="An efficient theorem prover"
-HOMEPAGE="https://github.com/Z3Prover/z3/"
-SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
-S=${WORKDIR}/z3-${P}
-
-SLOT="0/4.8"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
-IUSE="doc examples gmp isabelle java python"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.8 )"
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )"
-
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-src_prepare() {
- cmake_src_prepare
- java-pkg-opt-2_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
- -DZ3_USE_LIB_GMP=$(usex gmp)
- -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
- -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
- -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
- -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
- -DZ3_INCLUDE_GIT_DESCRIBE=OFF
- -DZ3_INCLUDE_GIT_HASH=OFF
- )
-
- multilib_is_native_abi && use java && mycmakeargs+=( -DJAVA_HOME="$(java-config -g JAVA_HOME )" )
-
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build test-z3
- set -- "${BUILD_DIR}"/test-z3 /a
- echo "${@}" >&2
- "${@}" || die
-}
-
-multilib_src_install_all() {
- dodoc README.md RELEASE_NOTES
- use examples && dodoc -r examples
- use python && python_optimize
-
- if use isabelle; then
- insinto /usr/share/Isabelle/contrib/${P}/etc
- newins - settings <<-EOF
- Z3_COMPONENT="\$COMPONENT"
- Z3_HOME="${EPREFIX}/usr/bin"
- Z3_SOLVER="${EPREFIX}/usr/bin/z3"
- Z3_REMOTE_SOLVER="z3"
- Z3_VERSION="${PV}"
- Z3_INSTALLED="yes"
- Z3_NON_COMMERCIAL="yes"
- EOF
- fi
-}
-
-pkg_postinst() {
- if use isabelle; then
- if [[ -f ${ROOT}/etc/isabelle/components ]]; then
- sed -e "/contrib\/${PN}-[0-9.]*/d" \
- -i "${ROOT}/etc/isabelle/components" || die
- cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
- contrib/${P}
- EOF
- fi
- fi
-}
-
-pkg_postrm() {
- if use isabelle; then
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
- # Note: this sed should only match the version of this ebuild
- # Which is what we want as we do not want to remove the line
- # of a new Isabelle component being installed during an upgrade.
- sed -e "/contrib\/${P}/d" \
- -i "${ROOT}/etc/isabelle/components" || die
- fi
- fi
- fi
-}
diff --git a/sci-mathematics/z3/z3-4.8.16.ebuild b/sci-mathematics/z3/z3-4.8.16.ebuild
deleted file mode 100644
index 7ebfae64d20b..000000000000
--- a/sci-mathematics/z3/z3-4.8.16.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_ECLASS=cmake
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake-multilib java-pkg-opt-2 python-single-r1
-
-DESCRIPTION="An efficient theorem prover"
-HOMEPAGE="https://github.com/Z3Prover/z3/"
-SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
-S=${WORKDIR}/z3-${P}
-
-SLOT="0/4.8"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="doc examples gmp isabelle java python"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- java? ( >=virtual/jdk-1.8 )
-"
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
-"
-
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-src_prepare() {
- cmake_src_prepare
- java-pkg-opt-2_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
- -DZ3_USE_LIB_GMP=$(usex gmp)
- -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
- -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
- -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
- -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
- -DZ3_INCLUDE_GIT_DESCRIBE=OFF
- -DZ3_INCLUDE_GIT_HASH=OFF
- )
-
- multilib_is_native_abi && use java && mycmakeargs+=( -DJAVA_HOME="$(java-config -g JAVA_HOME )" )
-
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build test-z3
- set -- "${BUILD_DIR}"/test-z3 /a
- echo "${@}" >&2
- "${@}" || die
-}
-
-multilib_src_install_all() {
- dodoc README.md RELEASE_NOTES
- use examples && dodoc -r examples
- use python && python_optimize
-
- if use isabelle; then
- insinto /usr/share/Isabelle/contrib/${P}/etc
- newins - settings <<-EOF
- Z3_COMPONENT="\$COMPONENT"
- Z3_HOME="${EPREFIX}/usr/bin"
- Z3_SOLVER="${EPREFIX}/usr/bin/z3"
- Z3_REMOTE_SOLVER="z3"
- Z3_VERSION="${PV}"
- Z3_INSTALLED="yes"
- Z3_NON_COMMERCIAL="yes"
- EOF
- fi
-}
-
-pkg_postinst() {
- if use isabelle; then
- if [[ -f ${ROOT}/etc/isabelle/components ]]; then
- sed -e "/contrib\/${PN}-[0-9.]*/d" \
- -i "${ROOT}/etc/isabelle/components" || die
- cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
- contrib/${P}
- EOF
- fi
- fi
-}
-
-pkg_postrm() {
- if use isabelle; then
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
- # Note: this sed should only match the version of this ebuild
- # Which is what we want as we do not want to remove the line
- # of a new Isabelle component being installed during an upgrade.
- sed -e "/contrib\/${P}/d" \
- -i "${ROOT}/etc/isabelle/components" || die
- fi
- fi
- fi
-}