summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-27 14:17:10 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-27 14:17:10 +0200
commit06b909378fcc397842f828d34f66b61130f101cc (patch)
treeb6eb1eea9cfc69fcfa43e2859f6beb0c20cd5c57
parentxfce-base/exo: Drop old (diff)
downloadgentoo-06b909378fcc397842f828d34f66b61130f101cc.tar.gz
gentoo-06b909378fcc397842f828d34f66b61130f101cc.tar.bz2
gentoo-06b909378fcc397842f828d34f66b61130f101cc.zip
dev-util/catfish: Bump to 1.4.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-1.4.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index e9b2ee46509e..72a62f6ab4cb 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1 +1,2 @@
DIST catfish-1.4.7.tar.bz2 162289 BLAKE2B 2f24485f0f059a177a8544632ab583acad1149f96921f8b10027e5788adb2eaf4da0911f3363174feef570c8f75615ec1f943a2d5d2e8622efd4be9892a0fcd2 SHA512 cafa8eaaa40522f50111b3bb9c09a116ebad827532b0cfc88bc643fb2e2d89edee53057fbbed23719f4091ca384d7ea025633e571e160d7dfced008f788a3ffd
+DIST catfish-1.4.8.tar.bz2 181027 BLAKE2B c03270832cb2e6bdc39528801d257d37c52f0c6f361c9225002c31a258a18a1c98cf7af640ca15a4f6e32ac4ac802bda84327123a7bf13d47a1410e67988bfab SHA512 46c9e9112116e0f8ee7957c5a71d16ecdde8c16a60a030f3339933a6f9e73d61d360fed52d5904b0fff21448050cc17df5af63f6254476404760fe9166dfad00
diff --git a/dev-util/catfish/catfish-1.4.8.ebuild b/dev-util/catfish/catfish-1.4.8.ebuild
new file mode 100644
index 000000000000..a6d1ef38c048
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ rm -r "${ED%/}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}