summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-12-01 17:46:43 -0500
committerAaron Bauman <bman@gentoo.org>2018-12-01 17:46:43 -0500
commit06bb1dfb75fa11ab7bd3754eebedb586213a8d02 (patch)
tree886b33bbe5b4b58fac7ebbeba2a3c1b353bef96a
parentsys-fs/eudev: fix bug #666892, comment #10 (diff)
downloadgentoo-06bb1dfb.tar.gz
gentoo-06bb1dfb.tar.bz2
gentoo-06bb1dfb.zip
dev-libs/light: new package
Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-libs/light/Manifest1
-rw-r--r--dev-libs/light/light-1.2.ebuild29
-rw-r--r--dev-libs/light/metadata.xml11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/light/Manifest b/dev-libs/light/Manifest
new file mode 100644
index 000000000000..bb1931fe604d
--- /dev/null
+++ b/dev-libs/light/Manifest
@@ -0,0 +1 @@
+DIST light-1.2.tar.gz 32592 BLAKE2B 86d2bf4a88cf61ec1b7af16510db3d26698397d5cc3ddee7f663c1f501ca6b5bf238e5f29f17142d6196908e1d444795abed41a12560c9411214d4a874c96ddb SHA512 3f876262a730ef34219e0d596065c725376218ca88a2e9f56f62a25956b9ba505168f32c5877715abf746090c053873322a3292680055cc2f5b77ec8c0d466a4
diff --git a/dev-libs/light/light-1.2.ebuild b/dev-libs/light/light-1.2.ebuild
new file mode 100644
index 000000000000..adc2243bbb00
--- /dev/null
+++ b/dev-libs/light/light-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A program to control backlights (and other hardware lights)"
+HOMEPAGE="https://github.com/haikarainen/light"
+SRC_URI="https://github.com/haikarainen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="udev"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ use udev && econf \
+ --with-udev="/lib/udev/rules.d"
+}
diff --git a/dev-libs/light/metadata.xml b/dev-libs/light/metadata.xml
new file mode 100644
index 000000000000..62e9eba6759d
--- /dev/null
+++ b/dev-libs/light/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">haikarainen/light</remote-id>
+ </upstream>
+</pkgmetadata>