summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 20:39:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 20:42:06 +0200
commit06bca4f96693b3d63c2868d1fb8992aa9090c26e (patch)
tree2787211c2d27cd36ceb3430e82aee560f3046628
parentdev-python/virtualenv: Remove old (diff)
downloadgentoo-06bca4f9.tar.gz
gentoo-06bca4f9.tar.bz2
gentoo-06bca4f9.zip
dev-python/flask-wtf: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-wtf/Manifest1
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.15.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flask-wtf/Manifest b/dev-python/flask-wtf/Manifest
index 6c1bdfa924da..cdc8737c6321 100644
--- a/dev-python/flask-wtf/Manifest
+++ b/dev-python/flask-wtf/Manifest
@@ -1,2 +1,3 @@
DIST Flask-WTF-0.14.3.tar.gz 44507 BLAKE2B d160e10b1434c0578708c265468b77624953eb2d4ddde9a6ed2ff5b4f4651e0d5d2483020f51c9e512e3cb04895ecaa8fd1d0bf9380211d0a916acd8428f353a SHA512 58bdb87e442dd49dcbc9090e6466ecbd0b5c6bd2f097a26e071a5c73e09256ac46cc2f794f138f0e0b45e4f65ce70c231c275dc69aa44df408d7d79b15198832
DIST Flask-WTF-0.15.0.tar.gz 45382 BLAKE2B ff019200c48d69d223b71a7f666e413badddb70ed602bd428bcfe70522a66d4c39588e352969c883b017374bee83477765de1b347943923919ab1afd45c8a92f SHA512 51fa22f0397478a98bb0fceec78814740aa25e8ba19e8c5aae0a81056f65da55c7a412ae79548b907798e3561ad0ce64a826ad38b532cc912e9765a6474558b7
+DIST Flask-WTF-0.15.1.tar.gz 45540 BLAKE2B 95ed9efaa89b487f406811926a8b206d15ad9c065f99595a35ea2ca4f98ede671673204c4085de91afe1e1b91b611ceb0f43b9c68b46fdd0e38d9025ac666f70 SHA512 9741e2c2285a500866b160e8c906c38ca579fdae2235bcba2336c7125ba614a9f75167c82bfcb96a45e553170c5925cb1a530d0164ecc57dc76cf1b560c40855
diff --git a/dev-python/flask-wtf/flask-wtf-0.15.1.ebuild b/dev-python/flask-wtf/flask-wtf-0.15.1.ebuild
new file mode 100644
index 000000000000..7db390002886
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.15.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms"
+HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tries to access things over the network
+ rm tests/test_recaptcha.py || die
+ distutils-r1_python_prepare_all
+}