summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-17 13:14:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-17 14:32:32 +0100
commit06c3358fe628aaeaae589449407ea5e7a6fcee8d (patch)
treeac0a1d42d0c7ddd8acaaa267b98f9b1cecb75a4f
parentdev-python/boto3: Bump to 1.29.2 (diff)
downloadgentoo-06c3358fe628aaeaae589449407ea5e7a6fcee8d.tar.gz
gentoo-06c3358fe628aaeaae589449407ea5e7a6fcee8d.tar.bz2
gentoo-06c3358fe628aaeaae589449407ea5e7a6fcee8d.zip
app-admin/awscli: Bump to 1.30.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.30.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 49d1ea2c2def..e35da93d6a29 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.29.84.gh.tar.gz 2576584 BLAKE2B c442a433b0deaacb8b0a94ecb4ce296b6
DIST aws-cli-1.29.85.gh.tar.gz 2577082 BLAKE2B 8d16b3a989b6a12a154baa8b5d25be6c35c6201f6041cc9f100274815f746c55b1107274575dee928250743b72f02d3db17c8198a9fd3bff7c3bcd827def5cdb SHA512 88164eeddc9d99811d20aa7cd607720fafaa8324738db3eb0aaa76cdb2e8710b828f64c0da3fb14409130fb41880c724918617742a1a3e8d92200f9707865db8
DIST aws-cli-1.30.0.gh.tar.gz 2584557 BLAKE2B d88e0987b019ca6a86ffb599ee894b8270dda4c4cae2a4bf0a74438d821533d5875d379132f76c70e93bc8b3136f3a8374b60d797f064921597b259589bd5bfe SHA512 5fd1ee8e4f978cfc4964799b3556eae8c0a7cec367dd4f0c096971a948d1ce7b8bc008b05e84c67723f0d603470777d075cc12a014cb2466789033de62e9078e
DIST aws-cli-1.30.1.gh.tar.gz 2586590 BLAKE2B 6520fcb6818213d4ad9c002cf4dddcf16b35c32fe0a0048a3247a1ba3fd7cbfb32df95715d4397132a0229cdf5aebbe9635f012c5e4f8fa212f41c5a8e1c07bf SHA512 78f7bd8286cdd5e433e2024c0bcac3cf3a9a74f9eca344c4d09b0506c314b3e38c34d8d2c85bbc91a3ac6395bbc319c6bb91536a364a587e7c27902362fdc005
+DIST aws-cli-1.30.2.gh.tar.gz 2589683 BLAKE2B 786aad7e939d3d8349d2d1930c82bad7b0bcdaa36f9df389f155f23e610019ff2f0bdd52da2d6ac4f4e1896a236d7aee895641245a518a3cb094ba3e43e3a594 SHA512 8fbbe9b951942d7230d9875a153403f2fa952657e124686926d94a6f816b9ae093ec025b595ccd7f7a532a930b8b3e516f1030ba7d7038dddaa188c5d3ee5ea9
diff --git a/app-admin/awscli/awscli-1.30.2.ebuild b/app-admin/awscli/awscli-1.30.2.ebuild
new file mode 100644
index 000000000000..e5b1ee0667a3
--- /dev/null
+++ b/app-admin/awscli/awscli-1.30.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}