summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 18:30:06 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:28 +0200
commit06d4a9d8181ff1e82a447d53863b88965ce07b88 (patch)
treece26ca4d120e74d8280b92406242d61bdeefa8c4
parentx11-plugins/wmbutton: EAPI8 bump (diff)
downloadgentoo-06d4a9d8181ff1e82a447d53863b88965ce07b88.tar.gz
gentoo-06d4a9d8181ff1e82a447d53863b88965ce07b88.tar.bz2
gentoo-06d4a9d8181ff1e82a447d53863b88965ce07b88.zip
x11-plugins/wmcliphist: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild b/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild
new file mode 100644
index 000000000000..1357a842a0ca
--- /dev/null
+++ b/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="https://www.dockapps.net/wmcliphist"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+S="${WORKDIR}/dockapps"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:3[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -e '/^PREFIX/s:=.*:=/usr:' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ newdoc ${PN}rc ${PN}rc.sample
+}