summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-01 20:47:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-01 21:08:16 +0200
commit06dfc67c005ed305d7f572ad940da3a75167c3eb (patch)
tree1caa26c21abe7aa8e34fdc3663bd4a5e78698083
parentapp-backup/amanda: cleanup, per bug #537248. (diff)
downloadgentoo-06dfc67c.tar.gz
gentoo-06dfc67c.tar.bz2
gentoo-06dfc67c.zip
media-sound/qmpdclient: Fix DEPENDs
Gentoo-bug: 620714 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.2.2-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/qmpdclient/qmpdclient-1.2.2-r3.ebuild b/media-sound/qmpdclient/qmpdclient-1.2.2-r3.ebuild
new file mode 100644
index 000000000000..014cca271ad6
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.2.2-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fdo-mime cmake-utils
+
+DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
+HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
+SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+DEPEND="
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtxmlpatterns:4
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README THANKSTO )
+
+PATCHES=( "${FILESDIR}"/${P}-qt48.patch )
+
+src_prepare() {
+ sed -i -e "/^Categories/s/Network/AudioVideo/" ${PN}.desktop || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( "-DVERSION=${PV}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }