summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2015-11-26 03:35:10 +0000
committerIan Delaney <idella4@gentoo.org>2015-11-27 11:59:22 +0800
commit071b2cd2960c482bfcb7f5463591778f36272945 (patch)
tree12da5bc6b9ef051d05161190ee4171f2011a6837
parentdev-perl/Module-ScanDeps: Version bump. (diff)
downloadgentoo-071b2cd2.tar.gz
gentoo-071b2cd2.tar.bz2
gentoo-071b2cd2.zip
app-doc/kicad-doc-4.0.0-rc1: New KiCad documentation ebuild
KiCad extended documentation for 4.0.0-rc1, amending help with more details and tutorials. Upstream split the docs off the main source into a separate package. Gentoo-Bug: #564704
-rw-r--r--app-doc/kicad-doc/Manifest1
-rw-r--r--app-doc/kicad-doc/kicad-doc-4.0.0_rc1.ebuild62
-rw-r--r--app-doc/kicad-doc/metadata.xml22
3 files changed, 85 insertions, 0 deletions
diff --git a/app-doc/kicad-doc/Manifest b/app-doc/kicad-doc/Manifest
new file mode 100644
index 000000000000..8d8ba826abe2
--- /dev/null
+++ b/app-doc/kicad-doc/Manifest
@@ -0,0 +1 @@
+DIST kicad-doc-4.0.0_rc1.tar.gz 35078269 SHA256 3e26397455f36ff902f3c93d32b4c0063f44069e88a0d477475bb0b1dbf75140 SHA512 77c5ae067ec480ae0bec4fe8b6de53d05e675ba29695b5de2b39d9019262cd2b376123e8f978db5d362b157b8dd6fba8ecf1604262d0ae31ee5a37de5538dff7 WHIRLPOOL 9afebc3419a69d57377ec10c44d5a4346bd6ccb75c50795809205e9490f35fdd7d0046a37319d49a99766aecec53c8b0287d1beca4788310a957bf854f58e641
diff --git a/app-doc/kicad-doc/kicad-doc-4.0.0_rc1.ebuild b/app-doc/kicad-doc/kicad-doc-4.0.0_rc1.ebuild
new file mode 100644
index 000000000000..98fd3ce5482f
--- /dev/null
+++ b/app-doc/kicad-doc/kicad-doc-4.0.0_rc1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils vcs-snapshot
+
+# As per KiCad site the version of docs they will bundle with 4.0.0 final
+# is the state of the docs at the release date. Thus I will follow the same
+# logic when picking revisions for KiCad-4.0.0 RCs
+DOC_REVISION="b5e8a2efb9015b420bd83541d4b580ce2f7a89e6"
+
+DESCRIPTION="Electronic Schematic and PCB design tools manuals."
+HOMEPAGE="http://www.kicad-pcb.org"
+SRC_URI="https://github.com/KiCad/${PN}/tarball/${DOC_REVISION} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+FUSE="html pdf"
+LANGS="en fr it ja nl pl"
+LINGUAS=""
+for lang in ${LANGS} ; do
+ LINGUAS="${LINGUAS} linguas_${lang}"
+done
+IUSE="${FUSE} ${LINGUAS}"
+
+REQUIRED_USE="( || ( pdf html ) ) ( ^^ ( ${LINGUAS} ) )"
+
+DEPEND=">=app-text/asciidoc-8.6.9
+ app-text/dblatex
+ >=app-text/po4a-0.45
+ >=sys-devel/gettext-0.18
+ dev-util/source-highlight
+ dev-perl/Unicode-LineBreak
+ linguas_ja? ( media-fonts/vlgothic )"
+RDEPEND=""
+
+src_configure() {
+ local formats=""
+ local doclang=""
+
+ # construct format string
+ for format in ${FUSE}; do
+ use $format && formats+="${format};"
+ done
+
+ # find out which language is requested
+ for lang in ${LANGS}; do
+ if use linguas_${lang}; then
+ doclang=${lang}
+ fi
+ done
+
+ local mycmakeargs+=(
+ -DBUILD_FORMATS="${formats}"
+ -DSINGLE_LANGUAGE="${doclang}"
+ -DCMAKE_INSTALL_PREFIX="/usr/share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-doc/kicad-doc/metadata.xml b/app-doc/kicad-doc/metadata.xml
new file mode 100644
index 000000000000..eab80cf16da0
--- /dev/null
+++ b/app-doc/kicad-doc/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>zoltan@sinustrom.info</email>
+ <name>Zoltan Puskas</name>
+ <description>Proxied maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <use>
+ <flag name="html">Generate documentation in HTML format</flag>
+ <flag name="pdf">Generate documentation in PDF format</flag>
+ </use>
+ <longdescription>
+ Kicad-doc is the extended manuals and documenation for Kicad. Kicad is
+ an open source (GPL) software for the creation of electronic schematic
+ diagrams and printed circuit board artwork.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">KiCad/kicad-doc</remote-id>
+ </upstream>
+</pkgmetadata>