summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-21 10:14:47 +0100
committerDavid Seifert <soap@gentoo.org>2017-09-23 10:36:15 +0200
commit072d9adafab829b7f934637f7ba8a8f29c2ea3db (patch)
treec88542658849c15f2dc1a3f97ab7ef2e564cdad6
parentmedia-libs/opencolorio: Update to v20170719 (diff)
downloadgentoo-072d9adafab829b7f934637f7ba8a8f29c2ea3db.tar.gz
gentoo-072d9adafab829b7f934637f7ba8a8f29c2ea3db.tar.bz2
gentoo-072d9adafab829b7f934637f7ba8a8f29c2ea3db.zip
media-libs/opensubdiv: Version bump to 3.3 and remove ati-drivers
* Fixed compile error about stray quotes * Changed hardcoded paths to GNUInstallDirs which fixed multilib-strict check fail Closes: https://bugs.gentoo.org/605958 Closes: https://bugs.gentoo.org/611844 Closes: https://github.com/gentoo/gentoo/pull/5751
-rw-r--r--media-libs/opensubdiv/Manifest1
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch13
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch39
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.0.ebuild2
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.1.ebuild9
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.0.ebuild63
6 files changed, 123 insertions, 4 deletions
diff --git a/media-libs/opensubdiv/Manifest b/media-libs/opensubdiv/Manifest
index a86411c5c8d5..26ccdac0e659 100644
--- a/media-libs/opensubdiv/Manifest
+++ b/media-libs/opensubdiv/Manifest
@@ -1,2 +1,3 @@
DIST opensubdiv-3.1.0.tar.gz 18014579 SHA256 ff3f2cdeeaa8ac4abe83394b1fea27ea3ade8258aff86da5fdfba37415485aba SHA512 9b59cb4e5b124e222b67a48986251cff91bcdc2aee9f71c4b653ad7bb089e860c5954c251a91c0004fa5c28fc4524a0dcbf51d3ae51ea86ee7665ba05d8ec97f WHIRLPOOL 0765a01209781b237df9f51717d7e14dcde57b5e00e7cfaa81e02d6fd409bb2df3bc7c95f26b5ed20bb8cbd6c2b3aaa9ad28861198c25ffd3ec3c6b699a32444
DIST opensubdiv-3.1.1.tar.gz 18014871 SHA256 6a2043c0c8b6e85bdc34dbd6d05e6bc7504a4d01dcfb165b4abe180c50d41164 SHA512 700db7e1dde3e916011721a5b42d5e32ea4ae355ab5e3e415541d62efa2059d56d5f30cef853285e95a93f3a3b5fe24a906547a52cce94d47b101ae20021d5b5 WHIRLPOOL b36136cc88e2f68d6ddb94ad500b449fb8ea9c0104b864d873ac7fd2966ac8ee44d7f4296ad96bcb65ae9f7858f1c6a9703f6d90754bd0dd1ad27db1b9fc1628
+DIST opensubdiv-3.3.0.tar.gz 19263469 SHA256 93d364340518515129fe199c80c4030f666ff71414d9c543e1526f14b5ffc8d0 SHA512 7c17d847187d46182d08fbee9396fd8793ac04591821084d40da475c9d25560d01575282946e1a30252bba12db9ea06cbf50ff649f91adce72f6127ad6a36418 WHIRLPOOL a1915d3fff1bce076f22bdc64efc0c07c372614d6ee0b36548bad9310da7a1c9a8863a3f638e07091cef28b99c01b6d77f0a9301415044806976674f434a7195
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch b/media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch
new file mode 100644
index 000000000000..2b5c71a37cb5
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e02ce90c..6d4f5342 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -48,7 +48,7 @@ endif()
+ string(REGEX REPLACE "^v" "" OSD_SONAME ${OSD_SONAME})
+
+ add_definitions(
+- -DOPENSUBDIV_VERSION_STRING="${OSD_SONAME}"
++ -DOPENSUBDIV_VERSION_STRING=\\\"${OSD_SONAME}\\\"
+ )
+
+ #-------------------------------------------------------------------------------
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch b/media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch
new file mode 100644
index 000000000000..02027763f5ca
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch
@@ -0,0 +1,39 @@
+diff -purN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2017-07-25 21:58:09.000000000 +0100
++++ b/CMakeLists.txt 2017-08-15 14:51:36.771044414 +0100
+@@ -23,6 +23,7 @@
+ #
+
+ project(OpenSubdiv)
++include(GNUInstallDirs)
+
+ cmake_minimum_required(VERSION 2.8.6)
+
+@@ -63,15 +64,15 @@ if (NOT DEFINED CMAKE_INSTALL_PREFIX)
+ endif()
+
+ if (NOT DEFINED CMAKE_INCDIR_BASE)
+- set( CMAKE_INCDIR_BASE include/opensubdiv )
++ set( CMAKE_INCDIR_BASE ${CMAKE_INSTALL_INCLUDEDIR}/opensubdiv )
+ endif()
+
+ if (NOT DEFINED CMAKE_BINDIR_BASE)
+- set( CMAKE_BINDIR_BASE bin )
++ set( CMAKE_BINDIR_BASE ${CMAKE_INSTALL_BINDIR} )
+ endif()
+
+ if (NOT DEFINED CMAKE_LIBDIR_BASE)
+- set( CMAKE_LIBDIR_BASE lib )
++ set( CMAKE_LIBDIR_BASE ${CMAKE_INSTALL_LIBDIR} )
+ endif()
+
+ if (NOT DEFINED CMAKE_FRAMEWORKDIR_BASE)
+@@ -83,7 +84,7 @@ if (NOT DEFINED CMAKE_PLUGINDIR_BASE)
+ endif()
+
+ if (NOT DEFINED CMAKE_DOCDIR_BASE)
+- set( CMAKE_DOCDIR_BASE share/doc/opensubdiv )
++ set( CMAKE_DOCDIR_BASE ${CMAKE_INSTALL_DOCDIR} )
+ else()
+ if (IS_ABSOLUTE ${CMAKE_DOCDIR_BASE})
+ set( CMAKE_DOCDIR_BASE "${CMAKE_DOCDIR_BASE}" )
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
index c729c1d79908..d822c40cc99e 100644
--- a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
@@ -15,10 +15,8 @@ LICENSE="ZLIB"
SLOT="0"
IUSE="cuda doc examples opencl openmp ptex tbb test tutorials"
-# OpenCL does not work with Open Source drivers.
RDEPEND="media-libs/glew:=
media-libs/glfw:=
- opencl? ( x11-drivers/ati-drivers:* )
cuda? ( dev-util/nvidia-cuda-toolkit:* )
ptex? ( media-libs/ptex )"
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
index df840a1c2750..0003926a6d4b 100644
--- a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
@@ -15,10 +15,8 @@ LICENSE="ZLIB"
SLOT="0"
IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
-# OpenCL does not work with Open Source drivers or nVidia binaries.
RDEPEND="media-libs/glew:=
media-libs/glfw:=
- opencl? ( x11-drivers/ati-drivers:* )
cuda? ( dev-util/nvidia-cuda-toolkit:* )
ptex? ( media-libs/ptex )"
@@ -38,6 +36,13 @@ pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e 's|"${OSD_SONAME}"|${OSD_SONAME}|' \
+ -i CMakeLists.txt || die
+}
+
src_configure() {
local mycmakeargs=(
-DNO_MAYA=1
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
new file mode 100644
index 000000000000..b73f2a25deb5
--- /dev/null
+++ b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils toolchain-funcs versionator
+
+MY_PV="$(replace_all_version_separators '_')"
+DESCRIPTION="An Open-Source subdivision surface library"
+HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
+SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
+
+RDEPEND="media-libs/glew:=
+ media-libs/glfw:=
+ cuda? ( dev-util/nvidia-cuda-toolkit:* )
+ ptex? ( media-libs/ptex )"
+
+DEPEND="${RDEPEND}
+ tbb? ( dev-cpp/tbb )
+ doc? (
+ dev-python/docutils
+ app-doc/doxygen
+ )"
+
+S="${WORKDIR}/OpenSubdiv-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-quotes.patch"
+ "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNO_MAYA=1
+ -DNO_CLEW=1
+ -DNO_DOC=$(usex !doc)
+ -DNO_TBB=$(usex !tbb)
+ -DNO_PTEX=$(usex !ptex)
+ -DNO_OMP=$(usex !openmp)
+ -DNO_OPENCL=$(usex !opencl)
+ -DNO_CUDA=$(usex !cuda)
+ -DNO_REGRESSION=1 # They don't work with certain settings
+ -DNO_EXAMPLES=$(usex !examples)
+ -DNO_TUTORIALS=$(usex !tutorials)
+ -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}