summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-01 00:52:19 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-01 01:50:09 +0100
commit0734d5b13d55d161629d6d1bcbcf2473cf889761 (patch)
tree7b02ca5edb066922c45067c67072311490f31194
parentsys-fs/multipath-tools: further plugindir fixes (diff)
downloadgentoo-0734d5b1.tar.gz
gentoo-0734d5b1.tar.bz2
gentoo-0734d5b1.zip
x11-themes/fluent-icon-theme: bump to 2022.11.30
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--x11-themes/fluent-icon-theme/Manifest1
-rw-r--r--x11-themes/fluent-icon-theme/fluent-icon-theme-2022.11.30.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-themes/fluent-icon-theme/Manifest b/x11-themes/fluent-icon-theme/Manifest
index 96842bd62b3b..f6fb1ba5b8ff 100644
--- a/x11-themes/fluent-icon-theme/Manifest
+++ b/x11-themes/fluent-icon-theme/Manifest
@@ -2,3 +2,4 @@ DIST fluent-icon-theme-2022.02.04.tar.gz 6742454 BLAKE2B 4795639edb540a2ab6e91f1
DIST fluent-icon-theme-2022.02.28.tar.gz 6125855 BLAKE2B 629de6f0ef9f5740124f2da53ecfff0e406af2e35d949c70447769397634cc2223afbc19d13c380f87b8ea19d78155fd3a7d971904238dc41ddb5cbf6007591c SHA512 04a65ac452f0f68a02ed849d4180766d1e893e4869b31c9f1dbe5938d7cc5a49cdb10409e5fa6b1cd3c27e309693774611a9fe9c431899aceda75f965da75e2a
DIST fluent-icon-theme-2022.09.20.tar.gz 5735903 BLAKE2B b2804099a5d362681fe53db3d496b8beb202ad2a4844e55724773f7b2d2aacf2948247867d4a06b128c2a56d86a231429d6efa5f47e90820203264e7edda2677 SHA512 46468b60778665dd24132776aed43d30385933cd8253cc5687ce89f5e9c933a64bf7823ee221f65248e39bc1e3e7ea0f76401e4908ddba54235d48113851d3b4
DIST fluent-icon-theme-2022.11.05.tar.gz 5817988 BLAKE2B 821b2d048ab818ff65b6295267023012143d46f087f14ff7ee34a5f2769847919c41dfe15b596ce4cd5f69475eb77686344b6742f7c70e6605ebc3ae80250e47 SHA512 52757ed27bae8bfb3199b005cfd524c2c1d604daa94af3ccfa9c31dbb9ea278edcd6b6aa7126df63284b1bd05058a6398a4cf7a7a42eedfd41cc4bb0dd600ca0
+DIST fluent-icon-theme-2022.11.30.tar.gz 5822571 BLAKE2B 876ef9350b10b868017195929f9b7503033785abfee020b6a0e3fe1820e481f52cebe3836ebfef2c075d65160425d804903b0f7e1e067b86d9cee559b23ceecd SHA512 20939ad5fd393971477cc66dcf1e5dd8e38ec6653daed206c003348daedc62e7bc485488327611f00fe26420b3bb4a8476035495f738af1f7fa407dd47e9efd1
diff --git a/x11-themes/fluent-icon-theme/fluent-icon-theme-2022.11.30.ebuild b/x11-themes/fluent-icon-theme/fluent-icon-theme-2022.11.30.ebuild
new file mode 100644
index 000000000000..82a474b46799
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/fluent-icon-theme-2022.11.30.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ie. 2021.12.20 -> 2021-12-20
+MY_PV="${PV//./-}"
+MY_PN="${PN^}"
+
+inherit xdg
+
+DESCRIPTION="Fluent icon theme for Linux desktops"
+HOMEPAGE="https://github.com/vinceliuice/Fluent-icon-theme"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+black +hardlink round"
+RESTRICT="binchecks strip test"
+
+BDEPEND="sys-apps/util-linux[hardlink(-)?]"
+
+src_prepare() {
+ default
+
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ dodir /usr/share/icons
+ local myinstallopts=(
+ --all
+ --dest "${ED}/usr/share/icons"
+ $(usev black '--black')
+ $(usev round '--round')
+ )
+ bash ./install.sh "${myinstallopts[@]}" || die "install script failed"
+
+ if use hardlink; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # installs broken symlink (by design, but we remove it due to QA warnings)
+ find "${ED}" -xtype l -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}