summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-22 00:25:00 +0000
committerSam James <sam@gentoo.org>2022-03-22 00:27:09 +0000
commit074f7df80d8ee17c4a9f076eee4791fd2eb1c021 (patch)
treeb9777ff1e3713facb442ae1ee3b7b60764a9013b
parentnet-p2p/qbittorrent: 4.4.1 version (diff)
downloadgentoo-074f7df80d8ee17c4a9f076eee4791fd2eb1c021.tar.gz
gentoo-074f7df80d8ee17c4a9f076eee4791fd2eb1c021.tar.bz2
gentoo-074f7df80d8ee17c4a9f076eee4791fd2eb1c021.zip
net-p2p/qbittorrent: sync live ebuild; port to CMake
- Sync live ebuild - Port to CMake (seems better supported upstream. autotools one doesn't seem to have received Qt 6 support, etc) - Fix musl build - Switch USE=X -> USE=gui per QA guidelines Bug: https://bugs.gentoo.org/834949 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild56
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild61
2 files changed, 63 insertions, 54 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild
index d95a557bc835..c7d3b847fcd7 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit xdg-utils
+inherit cmake systemd xdg
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org
@@ -20,50 +20,54 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus debug webui +X"
-REQUIRED_USE="dbus? ( X )"
+IUSE="+dbus gui webui"
+REQUIRED_USE="dbus? ( gui )"
RDEPEND="
>=dev-libs/boost-1.62.0-r1:=
dev-qt/qtcore:5
dev-qt/qtnetwork:5[ssl]
- dev-qt/qtxml:5
dev-qt/qtsql:5
- >=net-libs/libtorrent-rasterbar-1.2.12:0=
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.12:=
sys-libs/zlib
dbus? ( dev-qt/qtdbus:5 )
- X? (
+ gui? (
dev-libs/geoip
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
-
-BDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
src_configure() {
- econf \
- $(use_enable dbus qt-dbus) \
- $(use_enable debug) \
- $(use_enable webui) \
- $(use_enable X gui)
-}
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex gui)
+ -DWEBUI=$(usex webui)
-src_install() {
- emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
- einstalldocs
-}
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # We always want to install unit files
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
+ # Not yet in ::gentoo
+ -DQT6=OFF
+ )
+
+ cmake_src_configure
}
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
+src_install() {
+ cmake_src_install
+ einstalldocs
}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index f66536f7dc86..c7d3b847fcd7 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit xdg-utils
+inherit cmake systemd xdg
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org
@@ -14,55 +14,60 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
else
SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64 x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
S="${WORKDIR}/qBittorrent-release-${PV}"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus debug webui +X"
-REQUIRED_USE="dbus? ( X )"
+IUSE="+dbus gui webui"
+REQUIRED_USE="dbus? ( gui )"
RDEPEND="
>=dev-libs/boost-1.62.0-r1:=
dev-qt/qtcore:5
dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
dev-qt/qtxml:5
- >=net-libs/libtorrent-rasterbar-1.2.11:0=
+ >=net-libs/libtorrent-rasterbar-1.2.12:=
sys-libs/zlib
dbus? ( dev-qt/qtdbus:5 )
- X? (
+ gui? (
dev-libs/geoip
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
-
-BDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
src_configure() {
- econf \
- $(use_enable dbus qt-dbus) \
- $(use_enable debug) \
- $(use_enable webui) \
- $(use_enable X gui)
-}
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex gui)
+ -DWEBUI=$(usex webui)
-src_install() {
- emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
- einstalldocs
-}
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
+ # We always want to install unit files
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+ )
+
+ cmake_src_configure
}
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
+src_install() {
+ cmake_src_install
+ einstalldocs
}