summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:30:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:30:21 +0300
commit075e620b3a4d86f975512b50c094ad3024b38c5d (patch)
tree451f34127548a2a33ff2415c9d604db34ea2dfd4
parentdev-python/natsort: add 8.2.0 (diff)
downloadgentoo-075e620b.tar.gz
gentoo-075e620b.tar.bz2
gentoo-075e620b.zip
dev-python/python-swiftclient: add 4.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-swiftclient/Manifest1
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 05ac41ea40d0..26853db76d7c 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1 +1,2 @@
DIST python-swiftclient-4.0.1.tar.gz 201300 BLAKE2B 6a506ae8996a3937048f67e7b3f8e5185605f9e5fe955f23e1131eead4d3699fb01e7851ab632e3dfaa75c12e88ec17cec5b4c1b19c1663163a2ff95530561ec SHA512 0028bc12a9694047e31da3c05fe92ce846de8858743771281cc9b93f0826c596bb6ed5ee72f4e5c68c4bba2dbd9f311062dccdf13c9917536d2aaec7eaf33ef9
+DIST python-swiftclient-4.1.0.tar.gz 201954 BLAKE2B f81368dae2d0e56b178c00c9d4b0989fa9629fd909b8413a262103109a092bd8134679be41f8f8176d638f215d9e03b2e60013deed9f0b72d7ae4be181a1b4e0 SHA512 85b4ff0a49d149e6b42b257d8f815de48a549d377d7db807751f485d8a9636e4d4208c99cbd1cda3d9195c45d416911a4e8b65fc373e93d722cade0968515524
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.1.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.1.0.ebuild
new file mode 100644
index 000000000000..2336700dc435
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ # fix duplicate script/entry point
+ # https://bugs.launchpad.net/python-swiftclient/+bug/1975361
+ sed -i -e '/bin\/swift/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}