summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-10-17 07:23:20 +0200
committerUlrich Müller <ulm@gentoo.org>2023-10-17 07:33:16 +0200
commit076765e13d21be20b3e00bf60b7a9759f959bc8c (patch)
treeb32af0b6dfb49881d694d88126c865ea4d48e967
parentdev-lisp/c2ffi: Remove c2ffi-15.0.0, #905165 (diff)
downloadgentoo-076765e13d21be20b3e00bf60b7a9759f959bc8c.tar.gz
gentoo-076765e13d21be20b3e00bf60b7a9759f959bc8c.tar.bz2
gentoo-076765e13d21be20b3e00bf60b7a9759f959bc8c.zip
app-emacs/uboat: Fix a byte-compile warning
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/uboat/files/uboat-1.2-iap.patch11
-rw-r--r--app-emacs/uboat/uboat-1.2-r1.ebuild18
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/uboat/files/uboat-1.2-iap.patch b/app-emacs/uboat/files/uboat-1.2-iap.patch
new file mode 100644
index 000000000000..585b385a42e3
--- /dev/null
+++ b/app-emacs/uboat/files/uboat-1.2-iap.patch
@@ -0,0 +1,11 @@
+--- uboat-1.2/uboat.el
++++ uboat-1.2/uboat.el
+@@ -79,7 +79,7 @@
+ (let ((s (concat (uboat-iterate-list (uboat-random-member uboat-message)
+ "uboat-")
+ " U-" (int-to-string (random 999)) ".")))
+- (and (interactive-p)
++ (and (called-interactively-p 'interactive)
+ (message "%s" s))
+ s))
+
diff --git a/app-emacs/uboat/uboat-1.2-r1.ebuild b/app-emacs/uboat/uboat-1.2-r1.ebuild
new file mode 100644
index 000000000000..c440e10ac069
--- /dev/null
+++ b/app-emacs/uboat/uboat-1.2-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Generate u-boat-death messages, patterned after Iron Coffins"
+HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.bz2"
+
+# Noah Friedman and Bob Manson have confirmed that this is in the public domain
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-iap.patch" )
+SITEFILE="50${PN}-gentoo.el"