summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2022-01-02 22:00:37 -0600
committerJory Pratt <anarchy@gentoo.org>2022-01-02 22:00:51 -0600
commit07737b95af2452c0055e1ed0660590c1487befdb (patch)
tree5772f64308fd1f0d1afd243ede7bc2106828355e
parentsys-apps/shadow: add 4.11.1 (diff)
downloadgentoo-07737b95.tar.gz
gentoo-07737b95.tar.bz2
gentoo-07737b95.zip
app-forensics/chkrootkit: Fix missing includes for musl
Closes: https://bugs.gentoo.org/show_bug.cgi?id=715552 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.55.ebuild4
-rw-r--r--app-forensics/chkrootkit/files/chkrootkit-0.55-fcntl_h.patch30
-rw-r--r--app-forensics/chkrootkit/files/chkrootkit-0.55-limits_h.patch10
3 files changed, 43 insertions, 1 deletions
diff --git a/app-forensics/chkrootkit/chkrootkit-0.55.ebuild b/app-forensics/chkrootkit/chkrootkit-0.55.ebuild
index a81de87dc1c1..2e00fa511121 100644
--- a/app-forensics/chkrootkit/chkrootkit-0.55.ebuild
+++ b/app-forensics/chkrootkit/chkrootkit-0.55.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,8 @@ RDEPEND="cron? ( virtual/cron )"
PATCHES=(
"${WORKDIR}/${GENTOO_PATCH}"
+ "${FILESDIR}/${P}-fcntl_h.patch"
+ "${FILESDIR}/${P}-limits_h.patch"
)
src_prepare() {
diff --git a/app-forensics/chkrootkit/files/chkrootkit-0.55-fcntl_h.patch b/app-forensics/chkrootkit/files/chkrootkit-0.55-fcntl_h.patch
new file mode 100644
index 000000000000..26ab42c0e437
--- /dev/null
+++ b/app-forensics/chkrootkit/files/chkrootkit-0.55-fcntl_h.patch
@@ -0,0 +1,30 @@
+--- a/chklastlog.c
++++ b/chklastlog.c
+@@ -41,6 +41,7 @@ int main () { return 0; }
+ #include <stdlib.h>
+ #endif
+ #include <sys/stat.h>
++#include <fcntl.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <signal.h>
+--- a/chkproc.c
++++ b/chkproc.c
+@@ -62,6 +62,7 @@ int main (){ return 0; }
+ #include <string.h>
+ #include <errno.h>
+ #include <sys/types.h>
++#include <fcntl.h>
+ #include <dirent.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+--- a/chkwtmp.c
++++ b/chkwtmp.c
+@@ -25,6 +25,7 @@ int main () { return 0; }
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <fcntl.h>
+ #include <string.h>
+ #include <utmp.h>
+ #include <time.h>
diff --git a/app-forensics/chkrootkit/files/chkrootkit-0.55-limits_h.patch b/app-forensics/chkrootkit/files/chkrootkit-0.55-limits_h.patch
new file mode 100644
index 000000000000..8046e9488992
--- /dev/null
+++ b/app-forensics/chkrootkit/files/chkrootkit-0.55-limits_h.patch
@@ -0,0 +1,10 @@
+--- a/chkdirs.c
++++ b/chkdirs.c
+@@ -33,6 +33,7 @@
+ #include <sys/syslimits.h>
+ #endif
+
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/types.h>