summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2020-08-20 12:57:25 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2020-08-20 12:57:25 +0200
commit077f198277177f9ebf6c682ce5fd8498152f1068 (patch)
tree4c953e0449d959a99ec3dcc2fb5fa5e3fd18f541
parentdev-tex/rubber: Drop old (diff)
downloadgentoo-077f1982.tar.gz
gentoo-077f1982.tar.bz2
gentoo-077f1982.zip
dev-python/matterhook: version bump
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
-rw-r--r--dev-python/matterhook/Manifest1
-rw-r--r--dev-python/matterhook/matterhook-0.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/matterhook/Manifest b/dev-python/matterhook/Manifest
index e3d38bb3f442..9f6ba1a33e06 100644
--- a/dev-python/matterhook/Manifest
+++ b/dev-python/matterhook/Manifest
@@ -1 +1,2 @@
DIST matterhook-0.1.tar.gz 3150 BLAKE2B 841b64875d3ecc55c5056a15e07e8c46ac13ec48f1fd2752ec0c3934608172c8970cc4ad6ce984e227bef811aaee9ca2fc352afbf4e4925a6930adf798edbdd3 SHA512 1c9d264fb80b7d6d746f8379c869903e80f0b4a134efb3ca571630fdbe53eb7b1ac244470f7c2f8229cfe54e7597594427e253f35f0b103fc4c4123a935c5193
+DIST matterhook-0.2.tar.gz 4458 BLAKE2B 83dae9d38eaa9de3abdca4925378475660ab6f9571565f9275425cb9579397c2f3d106735d4268b7045d6af2572bdb8e1f60aa89030b1fa44c4c5c1b19fcd106 SHA512 aa476a00a5b571c5c8bb21eccc5b1c325e0932da7e4f8095e3ad29356afd4716384abfa9e4927a820e6d1fcf8e62a516943f6372d90cd7a9e76d0292c352c483
diff --git a/dev-python/matterhook/matterhook-0.2.ebuild b/dev-python/matterhook/matterhook-0.2.ebuild
new file mode 100644
index 000000000000..0a9016cec09b
--- /dev/null
+++ b/dev-python/matterhook/matterhook-0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interact with Mattermost incoming webhooks easily"
+HOMEPAGE="https://github.com/numberly/matterhook"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"