summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-31 08:54:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-31 08:56:33 +0200
commit078f0d4bc59ce8793a39c5404733500c371b74b1 (patch)
treed3b752762463e635f409281456a871422b38e3c9
parentdev-libs/apr-util: Revbump to remove mysql support (bug #620230). (diff)
downloadgentoo-078f0d4b.tar.gz
gentoo-078f0d4b.tar.bz2
gentoo-078f0d4b.zip
dev-libs/apr-util: Removed old.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-libs/apr-util/Manifest2
-rw-r--r--dev-libs/apr-util/apr-util-1.5.2.ebuild102
-rw-r--r--dev-libs/apr-util/apr-util-1.5.3-r2.ebuild113
3 files changed, 0 insertions, 217 deletions
diff --git a/dev-libs/apr-util/Manifest b/dev-libs/apr-util/Manifest
index 10dcdfeddf1b..3e63c2acac5c 100644
--- a/dev-libs/apr-util/Manifest
+++ b/dev-libs/apr-util/Manifest
@@ -1,3 +1 @@
-DIST apr-util-1.5.2.tar.bz2 693258 SHA256 9ace3d2e3129d5c244ef695a88b3b47897695e8e6ca2b96e92e4a635d9ed12a7 SHA512 14e890aa1a34369ddf0d041d397231e21994c0a51d3a07dd126985699184ee59c2df32dd752339dd90278988a9461c714f0a157126229be57450259646a1d6df WHIRLPOOL 94972bf43b21527015a489e640d81087021a7818fb4435b60a0b753d214e53b05630976894c81a70a069bb6918150c22df7621c63a539082a8b90ca442adce0e
-DIST apr-util-1.5.3.tar.bz2 695303 SHA256 78edb174f13e25ee15ded2b849b741a248b879a93a77a2d31c20f7e225be3968 SHA512 b03588fd10c8705ea72cb35e821a99ba160c5a480d91d766969672c72a4db5bc2ec01b13cbe0eccc1cd1eadd96e8198994296bc2f0232b3fce4e82271a382db6 WHIRLPOOL 4e3d131c2fcb5818db76c2d663caf7ab193a020011d21a1b03238075ba1ddb9778aa3df1e165cb13833efc446c81d13893a126d91e8da6cc55a5431e50f3b797
DIST apr-util-1.5.4.tar.bz2 694427 SHA256 a6cf327189ca0df2fb9d5633d7326c460fe2b61684745fd7963e79a6dd0dc82e SHA512 ca877d8e444218c4ba0f28063ee075ddcd6c0a487b692dc80ef442fe775ec4eeb337c6957853772e8082e27edcb450d7e909c2c6c3ab4a95bbf0a5ee5ea4a2d1 WHIRLPOOL bc4ce82785513f4bf2207bb26758abc79e6bfef62a57d3e2ead570abc618b321c302390b9dcd8eab1ec44a9e5d398c2cc4d35af2549636e20d7c20678725ac2e
diff --git a/dev-libs/apr-util/apr-util-1.5.2.ebuild b/dev-libs/apr-util/apr-util-1.5.2.ebuild
deleted file mode 100644
index a99ea02195d5..000000000000
--- a/dev-libs/apr-util/apr-util-1.5.2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
-# APR_PV="${PV}"
-APR_PV="1.4.6"
-
-inherit autotools db-use eutils libtool multilib toolchain-funcs
-
-DESCRIPTION="Apache Portable Runtime Utility Library"
-HOMEPAGE="http://apr.apache.org/"
-SRC_URI="mirror://apache/apr/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
-RESTRICT="test"
-
-RDEPEND="dev-libs/expat
- >=dev-libs/apr-${APR_PV}:1
- berkdb? ( >=sys-libs/db-4 )
- freetds? ( dev-db/freetds )
- gdbm? ( sys-libs/gdbm )
- ldap? ( =net-nds/openldap-2* )
- mysql? ( =virtual/mysql-5* )
- nss? ( dev-libs/nss )
- odbc? ( dev-db/unixODBC )
- openssl? ( dev-libs/openssl )
- postgres? ( dev-db/postgresql )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-DOCS=(CHANGES NOTICE README)
-
-src_prepare() {
- eautoreconf
-
- elibtoolize
-}
-
-src_configure() {
- local myconf
-
- tc-is-static-only && myconf+=" --disable-util-dso"
-
- if use berkdb; then
- local db_version
- db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
- db_version="$(db_ver_to_slot "${db_version}")"
- db_version="${db_version/\./}"
- myconf+=" --with-dbm=db${db_version} --with-berkeley-db=$(db_includedir 2> /dev/null):${EPREFIX}/usr/$(get_libdir)"
- else
- myconf+=" --without-berkeley-db"
- fi
-
- econf \
- --datadir="${EPREFIX}"/usr/share/apr-util-1 \
- --with-apr="${EPREFIX}"/usr \
- --with-expat="${EPREFIX}"/usr \
- --without-sqlite2 \
- $(use_with freetds) \
- $(use_with gdbm) \
- $(use_with ldap) \
- $(use_with mysql) \
- $(use_with nss) \
- $(use_with odbc) \
- $(use_with openssl) \
- $(use_with postgres pgsql) \
- $(use_with sqlite sqlite3) \
- ${myconf}
-}
-
-src_compile() {
- emake CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-
- if use doc; then
- emake dox
- fi
-}
-
-src_install() {
- default
-
- find "${ED}" -name "*.la" -exec rm -f {} +
- find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -exec rm -f {} +
-
- if use doc; then
- dohtml -r docs/dox/html/*
- fi
-
- if ! use static-libs; then
- find "${ED}" -name "*.a" -exec rm -f {} +
- fi
-
- # This file is only used on AIX systems, which Gentoo is not,
- # and causes collisions between the SLOTs, so remove it.
- rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
-}
diff --git a/dev-libs/apr-util/apr-util-1.5.3-r2.ebuild b/dev-libs/apr-util/apr-util-1.5.3-r2.ebuild
deleted file mode 100644
index dd48875a8781..000000000000
--- a/dev-libs/apr-util/apr-util-1.5.3-r2.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
-# APR_PV="${PV}"
-APR_PV="1.4.6"
-
-inherit autotools db-use eutils libtool multilib toolchain-funcs
-
-DESCRIPTION="Apache Portable Runtime Utility Library"
-HOMEPAGE="http://apr.apache.org/"
-SRC_URI="mirror://apache/apr/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
-RESTRICT="test"
-
-RDEPEND="dev-libs/expat
- >=dev-libs/apr-${APR_PV}:1
- berkdb? ( >=sys-libs/db-4 )
- freetds? ( dev-db/freetds )
- gdbm? ( sys-libs/gdbm )
- ldap? ( =net-nds/openldap-2* )
- mysql? ( =virtual/mysql-5* )
- nss? ( dev-libs/nss )
- odbc? ( dev-db/unixODBC )
- openssl? ( dev-libs/openssl )
- postgres? ( dev-db/postgresql )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.4.2
- doc? ( app-doc/doxygen )"
-
-DOCS=(CHANGES NOTICE README)
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-berkdb6.patch #476374
- epatch "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
- eautoreconf
- elibtoolize
-}
-
-src_configure() {
- local myconf=()
-
- tc-is-static-only && myconf+=( --disable-util-dso )
-
- if use berkdb; then
- local db_version
- db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
- db_version="$(db_ver_to_slot "${db_version}")"
- db_version="${db_version/\./}"
- myconf+=(
- --with-dbm=db${db_version}
- # We use $T for the libdir because otherwise it'd simply be the normal
- # system libdir. That's pointless as the compiler will search it for
- # us already. This makes cross-compiling and such easier.
- --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
- )
- else
- myconf+=( --without-berkeley-db )
- fi
-
- if use nss || use openssl ; then
- myconf+=( --with-crypto ) # 518708
- fi
-
- econf \
- --datadir="${EPREFIX}"/usr/share/apr-util-1 \
- --with-apr="${SYSROOT}${EPREFIX}"/usr \
- --with-expat="${EPREFIX}"/usr \
- --without-sqlite2 \
- $(use_with freetds) \
- $(use_with gdbm) \
- $(use_with ldap) \
- $(use_with mysql) \
- $(use_with nss) \
- $(use_with odbc) \
- $(use_with openssl) \
- $(use_with postgres pgsql) \
- $(use_with sqlite sqlite3) \
- "${myconf[@]}"
- # Use the current env build settings rather than whatever apr was built with.
- sed -i -r \
- -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
- -e "/^CC=/s:=.*:=$(tc-getCC):" \
- -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
- -e '/^LTFLAGS/s:--silent::' \
- build/rules.mk || die
-}
-
-src_compile() {
- emake
- use doc && emake dox
-}
-
-src_install() {
- default
-
- find "${ED}" -name "*.la" -delete
- find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete
- use static-libs || find "${ED}" -name "*.a" -delete
-
- use doc && dohtml -r docs/dox/html/*
-
- # This file is only used on AIX systems, which Gentoo is not,
- # and causes collisions between the SLOTs, so remove it.
- rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
-}