summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-06-18 14:08:46 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2023-06-18 14:09:13 +0200
commit07a58c6bb6b06c820d9aa6639c02bd4eb33e3a72 (patch)
tree0b5184ea8b52e000732ce11b76c969e2fdf66eb1
parentmedia-gfx/hydrus: Add 531 (diff)
downloadgentoo-07a58c6b.tar.gz
gentoo-07a58c6b.tar.bz2
gentoo-07a58c6b.zip
media-radio/tlf: Fix inclomplete prototypes
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--media-radio/tlf/files/tlf-1.4.1-prototypes.patch32
-rw-r--r--media-radio/tlf/tlf-1.4.1-r3.ebuild57
2 files changed, 89 insertions, 0 deletions
diff --git a/media-radio/tlf/files/tlf-1.4.1-prototypes.patch b/media-radio/tlf/files/tlf-1.4.1-prototypes.patch
new file mode 100644
index 000000000000..83ef30f5bc91
--- /dev/null
+++ b/media-radio/tlf/files/tlf-1.4.1-prototypes.patch
@@ -0,0 +1,32 @@
+diff --git a/src/muf.c b/src/muf.c
+index 6671651..3032685 100644
+--- a/src/muf.c
++++ b/src/muf.c
+@@ -196,8 +196,7 @@ int t;
+ double xn, xs, ls, h, ff, x, yn_, k, lm, u, a;
+
+
+-static double power(man, ex)
+-double man, ex;
++static double power(double man, double ex)
+ {
+ return exp(ex * log(man));
+ }
+diff --git a/src/qtcwin.c b/src/qtcwin.c
+index 7437767..8b6dee0 100644
+--- a/src/qtcwin.c
++++ b/src/qtcwin.c
+@@ -53,11 +53,11 @@
+
+
+ void init_qtc_panel();
+-void draw_qtc_panel();
++void draw_qtc_panel(int direction);
+ void start_qtc_recording();
+ void stop_qtc_recording();
+ void clear_help_block();
+-void show_help_msg();
++void show_help_msg(int msgidx);
+ void showfield(int fidx);
+ void modify_field(int pressed);
+ void delete_from_field(int dir);
diff --git a/media-radio/tlf/tlf-1.4.1-r3.ebuild b/media-radio/tlf/tlf-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..6458ed20c7d0
--- /dev/null
+++ b/media-radio/tlf/tlf-1.4.1-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib:=
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]
+ elibc_musl? ( sys-libs/argp-standalone )"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+PATCHES=( "${FILESDIR}/${P}-zone_nr.patch"
+ "${FILESDIR}/${P}-musl.patch"
+ "${FILESDIR}/${P}-missing-include.patch"
+ "${FILESDIR}/${P}-prototypes.patch"
+ )
+
+# suppress warning wrt 'implicit function declaration' in config logs
+# bug #899842
+QA_CONFIG_IMPL_DECL_SKIP=(
+ wget_wch # designed to check availability of various ncursesw
+ # header files
+ )
+
+src_prepare() {
+ if has_version '>=media-libs/hamlib-4.2' ; then
+ sed -i -e "s/FILPATHLEN/HAMLIB_FILPATHLEN/g" "${S}"/src/sendqrg.c || die
+ fi
+
+ eapply ${PATCHES[@]}
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ use elibc_musl && append-libs argp
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ filter-lto # bug # 876418
+ econf --enable-fldigi-xmlrpc
+}