summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-23 07:15:14 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-23 07:15:36 +0100
commit07ab1d8daf0c403dc3a003be236b86c3b8f46fbc (patch)
tree3c652fa1bb3b81ce3f753b6e239ada27d273ebd4
parentdev-libs/qxlsx: Stabilize 1.4.7 ppc64, #925285 (diff)
downloadgentoo-07ab1d8daf0c403dc3a003be236b86c3b8f46fbc.tar.gz
gentoo-07ab1d8daf0c403dc3a003be236b86c3b8f46fbc.tar.bz2
gentoo-07ab1d8daf0c403dc3a003be236b86c3b8f46fbc.zip
dev-ruby/pg: add 1.5.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.5.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index a45eaa318e9a..deb830c8d766 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -2,3 +2,4 @@ DIST pg-1.4.6.tar.gz 282608 BLAKE2B 73616b6ba0373ae81394188fd96d7ca37144b76e5e89
DIST pg-1.5.3.tar.gz 296167 BLAKE2B d1f3d0cfecd2cf006dae3373e378b7784d07d08710595b62c5b2f3e887b8e10f0fc06fb0fbb1cccb995a04c51ced781362ecfe7bc95a311c0609ffc62ed54a7e SHA512 d15f5ddcf83cf70df23cb1e127442ff94850aa47fa78f8fdf34aa88ae43039dca6395413e714b60bee9f825d1016e98fcf446b704bd9bebfc71c0a5a9109a73a
DIST pg-1.5.4-x86.patch 2744 BLAKE2B c60a007ac1133117f458f2bfcfeea7a009a21a865a93ff542e3e4237643f22344b042376c70d15c8c14baa3d5345aee032b61261d3e15e8300d960e548cf4ba0 SHA512 a82ef374c0774dd36e636a23c548fcda41533aadf63e8e6e80668c855037b5d75b4d90cb3cbd688b7bfa376f0505edc99586853132b8ebb9449476319545a347
DIST pg-1.5.4.tar.gz 298368 BLAKE2B 1028fac00371f9f769ee6c484a518149dc7c89e78ee8c05754a4412c4fec062f958de75bfbfb3f8c570e9598e439156e1d53ba00a8bc6e1be93d00412d153281 SHA512 87d950d2240e4d9d540f19ce89b945cb2b4a6d96e79dc7aa67a2dae014f1b20b307d2c195bfe3afe5c86894b94d379980fa2b7c4cf0e6a68a15c58b8d6d469f8
+DIST pg-1.5.5.tar.gz 299336 BLAKE2B 40410091a24929ee79c14cae8ec6e526a8db569f3f0d5c0637389a099caf8085189bec3fee69c52a07097e1aec62d8da0ee87cdc11118be5c7daefebd9e0019e SHA512 4cd12f2b30d9f853f9707d3329eda0999a7ed0f5ebdbbcb3110996db6d80ef6bb4331b3f6648b19f6fd3f63d928552b58190b34808ca714cbd72c54aeed43478
diff --git a/dev-ruby/pg/pg-1.5.5.ebuild b/dev-ruby/pg/pg-1.5.5.ebuild
new file mode 100644
index 000000000000..2f148b514659
--- /dev/null
+++ b/dev-ruby/pg/pg-1.5.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_GEMSPEC="pg.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc README.md History.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://github.com/ged/ruby-pg"
+SRC_URI="https://github.com/ged/ruby-pg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-${P}"
+
+LICENSE="|| ( BSD-2 Ruby-BSD )"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server(+),threads(+)] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -e "s:_relative ': './:" \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests that assume IPv4
+ sed -i -e '/expect.*hostaddr/ s:^:#:' spec/pg/connection_spec.rb || die
+
+ # Fails with network-sandbox
+ sed -i -e '/connects using without host but envirinment variables/askip "gentoo"' spec/pg/scheduler_spec.rb || die
+
+ # Avoid test that only works with bundled pg
+ sed -i -e '/tells about the libpq library path/askip "gentoo"' spec/pg_spec.rb || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}