summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-29 09:14:16 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-29 09:14:31 +0100
commit07afc9622a4dcc374a188a2627b28f3d2efea648 (patch)
treef5b782181ccb8d972b6ee6acfae87f8c4351bd04
parentmedia-sound/spotify: bump version to 1.0.98 (diff)
downloadgentoo-07afc962.tar.gz
gentoo-07afc962.tar.bz2
gentoo-07afc962.zip
www-client/firefox: enable --enable-rust-simd
Closes: https://bugs.gentoo.org/676696 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-65.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-65.0.ebuild b/www-client/firefox/firefox-65.0.ebuild
index 3fe4b27355a0..c8e59db836c4 100644
--- a/www-client/firefox/firefox-65.0.ebuild
+++ b/www-client/firefox/firefox-65.0.ebuild
@@ -405,6 +405,10 @@ src_configure() {
mozconfig_annotate '' --with-system-libevent="${SYSROOT}${EPREFIX}"/usr
fi
+ if ! use x86 && [[ ${CHOST} != armv*h* ]] ; then
+ mozconfig_annotate '' --enable-rust-simd
+ fi
+
# skia has no support for big-endian platforms
if [[ $(tc-endian) == "big" ]] ; then
mozconfig_annotate 'big endian target' --disable-skia
@@ -485,7 +489,6 @@ src_compile() {
addpredict /root
addpredict /etc/gconf
- set -x
fi
MOZ_MAKE_FLAGS="${MAKEOPTS} -O" SHELL="${SHELL:-${EPREFIX}/bin/bash}" MOZ_NOSPAM=1 ${_virtx} \