summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-17 00:30:33 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-17 00:54:34 -0500
commit07b916a2019c2df97a95023582aa3bc654605330 (patch)
tree50f4cccb3fb675f8e775d9d43936ff5b4f1e6ac4
parentgames-puzzle/pathological: enable py3.11 (diff)
downloadgentoo-07b916a2019c2df97a95023582aa3bc654605330.tar.gz
gentoo-07b916a2019c2df97a95023582aa3bc654605330.tar.bz2
gentoo-07b916a2019c2df97a95023582aa3bc654605330.zip
games-simulation/singularity: enable py3.11, use pep517
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-simulation/singularity/singularity-1.00-r2.ebuild (renamed from games-simulation/singularity/singularity-1.00-r1.ebuild)14
1 files changed, 9 insertions, 5 deletions
diff --git a/games-simulation/singularity/singularity-1.00-r1.ebuild b/games-simulation/singularity/singularity-1.00-r2.ebuild
index d1dcbba13215..faf2e9b246f6 100644
--- a/games-simulation/singularity/singularity-1.00-r1.ebuild
+++ b/games-simulation/singularity/singularity-1.00-r2.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit desktop distutils-r1
SINGULARITY_MUSIC="endgame-${PN}-music-007"
@@ -35,12 +36,15 @@ BDEPEND="app-arch/unzip"
distutils_enable_sphinx docs
distutils_enable_tests pytest
-src_install() {
- local DOCS=( AUTHORS.txt Changelog.txt README.txt TODO )
- distutils-r1_src_install
+python_install() {
+ distutils-r1_python_install
python_moduleinto ${PN}/music
- python_domodule ../${SINGULARITY_MUSIC}/.
+ python_domodule "${WORKDIR}"/${SINGULARITY_MUSIC}/.
+}
+
+python_install_all() {
+ dodoc AUTHORS.txt Changelog.txt README.txt TODO
newicon ${PN}/data/themes/default/images/icon.png ${PN}.png
domenu ${PN}.desktop