summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 12:29:58 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-20 12:48:45 +0200
commit07bb7b8a7d09e799c5cacde586759269cc838ecd (patch)
tree29ba10c2712f127a01a81ac22fc0a1e8c96f66ef
parentwww-apps/owncloud: maintenance release bumps (diff)
downloadgentoo-07bb7b8a7d09e799c5cacde586759269cc838ecd.tar.gz
gentoo-07bb7b8a7d09e799c5cacde586759269cc838ecd.tar.bz2
gentoo-07bb7b8a7d09e799c5cacde586759269cc838ecd.zip
dev-python/aiotest: Add package needed for aioeventlet tests
-rw-r--r--dev-python/aiotest/Manifest1
-rw-r--r--dev-python/aiotest/aiotest-0.3.ebuild28
-rw-r--r--dev-python/aiotest/metadata.xml7
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/aiotest/Manifest b/dev-python/aiotest/Manifest
new file mode 100644
index 000000000000..119ab8e00f42
--- /dev/null
+++ b/dev-python/aiotest/Manifest
@@ -0,0 +1 @@
+DIST aiotest-0.3.tar.gz 10146 SHA256 1c6e3e8d210d1a37b74b4264df26ae744d9f20762701c592c2b17b85632221f0 SHA512 6af65e283dfae1ff0f09fb09498f1a5be971daef4907c5079acc1c7ad353f4aa415e03f3fb18d9fac28c54abe35c9db917584082a56b4b43cd80cbf5fa689d59 WHIRLPOOL 6606a9151b5298a03f71eb6b6b8f4f5f21b0daae175e88951b0e0c992f79d2341d82919aa7e2d356b1938a63635596e50bf9c76341c9b32bc878d62b8ca09bd6
diff --git a/dev-python/aiotest/aiotest-0.3.ebuild b/dev-python/aiotest/aiotest-0.3.ebuild
new file mode 100644
index 000000000000..3ffcc8bb8bac
--- /dev/null
+++ b/dev-python/aiotest/aiotest-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Test suite for an implementation of asyncio (PEP 3156)"
+HOMEPAGE="https://bitbucket.org/haypo/aiotest"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local suite
+ python_is_python3 && suite=asyncio || suite=trollius
+ "${PYTHON}" "test_${suite}.py" || die "Tests fail with ${EPYHON} (${suite})"
+}
diff --git a/dev-python/aiotest/metadata.xml b/dev-python/aiotest/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/aiotest/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>