summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-27 23:59:44 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:16:23 +0200
commit07c082aed7d35797441eb20337ffdc3d0888b008 (patch)
tree33542a20e8540c6c661a538d4d61a0a10ca1ec2f
parentdev-util/buildbot-badges: add 3.4.0, enable py3.10, cleanup (diff)
downloadgentoo-07c082aed7d35797441eb20337ffdc3d0888b008.tar.gz
gentoo-07c082aed7d35797441eb20337ffdc3d0888b008.tar.bz2
gentoo-07c082aed7d35797441eb20337ffdc3d0888b008.zip
dev-util/buildbot-console-view: add 3.4.0, enable py3.10, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-3.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index 0f3b0be2d31d..351644937e9b 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -7,3 +7,4 @@ DIST buildbot-console-view-3.1.0.tar.gz 18730 BLAKE2B 61703292ddff90e096cd70a5f1
DIST buildbot-console-view-3.1.1.tar.gz 18731 BLAKE2B 266e08a04f5c6e618c101d5c7fcfaf08b7ad389346bce94f5e6e2a9cc3eb65906228c0ad12503a0ef1beb330b2f16ff3a532ac9861443018b7a5eb4c85488d64 SHA512 6287643f320a06bd56b8826fbca665a5a2d5bc0914c0dfd7b01fe273ce3220fd89a0267ed4bed979393b87d5a48fa53df579acc4df965be12f87eab43584eae5
DIST buildbot-console-view-3.2.0.tar.gz 18732 BLAKE2B e9629d9aac9534c5948732dd94a0cda9da77c391bb0748e06c6d8ef04540e6a09af709db2f0096c74d3b942e02733938913be2cdcf121812526ac299f59b2573 SHA512 478e2273660e8af1d0f2ec61d5197819ae71db23e1319ef7f7d3aaa99ab2023c954dd917bcb4eed3b92da5a13b174cf31e28408dc6cc64bd2284a87dcb0cecc2
DIST buildbot-console-view-3.3.0.tar.gz 18739 BLAKE2B f2e32336eaa7b7e98395a850310508f0bd69eb1e26830fa5692e61b864d48c348a3c7385f3f7eeaadb80c54077bfef4216ea161fb97484aa9657200ccc53b5be SHA512 3b2c64205bd46b01cb9e86d3e13d809c777ba433cf052d82ef7aa0951f0e47f1a08435ba34fd9e21c902ec3b67fa7ce2ce256f21f79d23a2e97f2fbe6315f920
+DIST buildbot-console-view-3.4.0.tar.gz 18732 BLAKE2B caeb78d4d3cc616edafccc5f78c1104469f77ead6ec31e7b9a741e43cb8d7140f8c44b57449bd6d97e35912787cbbeee5617bdf90ce7a15ebd023721160edc06 SHA512 072a4ca8d5677e68d2893684d68d4742d7a5546e128ae99bbec0385772a5df6c885bb62b855484543a42c95471aa828f8f3375770fc079997e5183cf3eda9db8
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-3.4.0.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-3.4.0.ebuild
new file mode 100644
index 000000000000..16cdd7ff13ac
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-3.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-console-view/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"